karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Anstey (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (KARAF-2167) org.apache.karaf.tooling.exam.container.internal.adaptions.KarafManipulatorFactory creates invalid version qualifier
Date Thu, 07 Feb 2013 18:57:12 GMT

     [ https://issues.apache.org/jira/browse/KARAF-2167?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jonathan Anstey updated KARAF-2167:
-----------------------------------

    Attachment: KARAF-2167.patch

Thinking about this as a fix. It works for me :) However, I'm wondering why this replacement
from '-' to '.' was needed in the first place. If there is some version value that this is
needed for I can rework the patch.
                
> org.apache.karaf.tooling.exam.container.internal.adaptions.KarafManipulatorFactory creates
invalid version qualifier
> --------------------------------------------------------------------------------------------------------------------
>
>                 Key: KARAF-2167
>                 URL: https://issues.apache.org/jira/browse/KARAF-2167
>             Project: Karaf
>          Issue Type: Bug
>    Affects Versions: 2.3.0
>            Reporter: Jonathan Anstey
>         Attachments: KARAF-2167.patch
>
>
> If you have a custom Karaf version with three dots already (ex. 2.3.0.fuse-71-047), when
KarafManipulatorFactory does karafVersion.replaceFirst("-", "."), it puts a fourth dot in
the qualifier, which is an invalid OSGi version.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message