karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christian Schneider (JIRA)" <j...@apache.org>
Subject [jira] [Created] (KARAF-4173) Uses constraint violation when installing activemq feature
Date Fri, 04 Dec 2015 14:38:11 GMT
Christian Schneider created KARAF-4173:
------------------------------------------

             Summary: Uses constraint violation when installing activemq feature
                 Key: KARAF-4173
                 URL: https://issues.apache.org/jira/browse/KARAF-4173
             Project: Karaf
          Issue Type: Bug
          Components: karaf-feature
    Affects Versions: 4.0.3
            Reporter: Christian Schneider
             Fix For: 4.0.4


When installing thre activemq-blueprint feature there sometimes is a strange uses constraint
violation. 
I think this should not cause an exceptions as both chains start and end in the same bundle.

{code}
karaf@root()> feature:repo-add activemq 5.13.0
Adding feature url mvn:org.apache.activemq/activemq-karaf/5.13.0/xml/features
karaf@root()> feature:install activemq-blueprint
Error executing command: Uses constraint violation. Unable to resolve resource org.apache.activemq.activemq-blueprint
[org.apache.activemq.activemq-blueprint/5.13.0] because it is exposed to package 'org.apache.aries.blueprint'
from resources org.apache.aries.blueprint.core [org.apache.aries.blueprint.core/1.4.5] and
org.apache.aries.blueprint.core [org.apache.aries.blueprint.core/1.4.5] via two dependency
chains.

Chain 1:
  org.apache.activemq.activemq-blueprint [org.apache.activemq.activemq-blueprint/5.13.0]
    import: (&(osgi.wiring.package=org.apache.aries.blueprint)(version>=1.0.0)(!(version>=2.0.0)))
     |
    export: osgi.wiring.package: org.apache.aries.blueprint
  org.apache.aries.blueprint.core [org.apache.aries.blueprint.core/1.4.5]

Chain 2:
  org.apache.activemq.activemq-blueprint [org.apache.activemq.activemq-blueprint/5.13.0]
    import: (&(osgi.wiring.package=org.apache.xbean.blueprint.context.impl)(version>=3.13.0)(!(version>=5.0.0)))
     |
    export: osgi.wiring.package=org.apache.xbean.blueprint.context.impl; uses:=org.apache.aries.blueprint
  org.apache.xbean.blueprint [org.apache.xbean.blueprint/3.18.0]
    import: (&(osgi.wiring.package=org.apache.aries.blueprint)(version>=1.0.0)(!(version>=2.0.0)))
     |
    export: osgi.wiring.package: org.apache.aries.blueprint
  org.apache.aries.blueprint.core [org.apache.aries.blueprint.core/1.4.5]
{code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message