karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Guillaume Nodet (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KARAF-4883) Multiple versions of transitive dependencies aren't packaged anymore
Date Thu, 09 Feb 2017 10:59:42 GMT

    [ https://issues.apache.org/jira/browse/KARAF-4883?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15859350#comment-15859350
] 

Guillaume Nodet commented on KARAF-4883:
----------------------------------------

Could you try removing the following line:
  https://github.com/apache/karaf/blob/master/tooling/karaf-maven-plugin/src/main/java/org/apache/karaf/tooling/utils/Dependency31Helper.java#L127

It seems to work in this use case, but I suspect it may lead to other problems.

I think a better way could be to not do any conflict resolution using maven, but grab the
list of first level dependencies that would make the list of bundles to install, then grab
the whole transitive graph of dependencies, and use the osgi resolver to compute the list
of bundles to actually use, and make them bundle dependencies in the feature.

> Multiple versions of transitive dependencies aren't packaged anymore
> --------------------------------------------------------------------
>
>                 Key: KARAF-4883
>                 URL: https://issues.apache.org/jira/browse/KARAF-4883
>             Project: Karaf
>          Issue Type: Question
>          Components: karaf-tooling
>    Affects Versions: 4.0.4, 4.0.7
>         Environment: Maven 3.0.5
> > Maven 3.1.0
>            Reporter: Fabian Bahle
>            Assignee: Guillaume Nodet
>              Labels: kar, karaf-maven-plugin
>         Attachments: pom.xml
>
>
> We have a maven project using the karaf-maven-plugin to create a kar within all my transitive
dependencies, besides others we have jackrabbit oak 1.5.12 and Swagger IO 1.5.10 both need
Google's guava, but Oak needs it in version 15.0 and Swagger IO needs version 18.0 (defined
in the imports section of the manifest). If I build my project with Maven 3.0.5 both versions
are bundled inside the kar, but as soon as I update Maven to 3.1.0 or newer only the older
version is inside the kar.
> Is there anything I'm missing in my plugin configuration?
> {code:xml}
> <plugin>
> 	<groupId>org.apache.karaf.tooling</groupId>
> 	<artifactId>karaf-maven-plugin</artifactId>
> 	<version>4.0.4</version>
> 	<extensions>true</extensions>
> 	<configuration>
> 		<startLevel>75</startLevel>
> 		<aggregateFeatures>true</aggregateFeatures>
> 	</configuration>
> </plugin>
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message