karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Markus von Rüden (JIRA) <j...@apache.org>
Subject [jira] [Comment Edited] (KARAF-5299) fragment bundle not bound to its host when using the command bundle:install
Date Thu, 26 Oct 2017 09:27:00 GMT

    [ https://issues.apache.org/jira/browse/KARAF-5299?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16220203#comment-16220203
] 

Markus von Rüden edited comment on KARAF-5299 at 10/26/17 9:26 AM:
-------------------------------------------------------------------

Hello, I encountered a maybe related issue with 4.1.2. 
If I install a host bundle and a bunch of fragments they show up correctly referenced after
a 
*bundle:refresh*
This is expected behaviour and was always like this.
However if I restart the container, they do not automatically refresh, which they did in earlier
versions of karaf.

After a restart even a *bundle:refresh* will not always work. Sometimes bundles will not resolve
their "relation".
Can you guys verify this, please?


was (Author: mvrueden):
Hello, I encountered a maybe related issue with 4.1.2. 
If I install a host bundle and a bunch of fragments they show up correctly referenced after
a `bundle:refresh`.
This is expected behaviour and was always like this.
However if I restart the container, they do not automatically refresh, which they did in earlier
versions of karaf.

After a restart even a `bundle:refresh` will not always work. Sometimes they will not resolve
their "relation".
Can you guys verify this, please?

> fragment bundle not bound to its host when using the command bundle:install
> ---------------------------------------------------------------------------
>
>                 Key: KARAF-5299
>                 URL: https://issues.apache.org/jira/browse/KARAF-5299
>             Project: Karaf
>          Issue Type: Bug
>    Affects Versions: 4.1.2
>            Reporter: Nicolas Brasey
>            Assignee: Jean-Baptiste Onofré
>
> When installing a fragment bundle with the command bundle:install, the fragment does
not get bound to its host. The fragment is bound correctly after a restart of karaf.
> Workaround:
> Install the fragment bundle with the deploy directory.
> EDIT:
> I did more tests, and found another inconsistency when uninstalling the fragment. So
here a more detailed scenario:
> When installing the fragment:
> a) the fragment is not automatically bound to the host
> b) Then, if I update the host, the fragment is bound correctly (Like Achim suggested)
> When uninstalling the fragment:
> a)  the host is still bound to the fragment, see below. As you can see, the host bundle
id 279 is bound to the fragments bundle id 280 which is not there any more  
> {code}
> 279 │ Active │  80 │ 1.10.0.SNAPSHOT                    │ dms-profiles-mgmt-impl,
Fragments: 280
> karaf@root()>     
> {code}
> b) Then, if I update the host, the fragment is still bound.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message