karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Commented] (KARAF-5883) Installing activemq-broker on karaf 4.2.1 doesn't work
Date Mon, 03 Sep 2018 18:41:00 GMT

    [ https://issues.apache.org/jira/browse/KARAF-5883?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16602398#comment-16602398
] 

Jean-Baptiste Onofré commented on KARAF-5883:
---------------------------------------------

{{shell-compat}} feature is installed ? Anyway, I have some WIP on ActiveMQ.

> Installing activemq-broker on karaf 4.2.1 doesn't work
> ------------------------------------------------------
>
>                 Key: KARAF-5883
>                 URL: https://issues.apache.org/jira/browse/KARAF-5883
>             Project: Karaf
>          Issue Type: Bug
>    Affects Versions: 4.2.1
>            Reporter: Orlando Bedoya Marin
>            Priority: Minor
>              Labels: activemq
>
> Installing activemq-broker on karaf 4.2.1 doesn't work
>  
> {code:java}
>         __ __                  ____      
>        / //_/____ __________ _/ __/      
>       / ,<  / __ `/ ___/ __ `/ /_        
>      / /| |/ /_/ / /  / /_/ / __/        
>     /_/ |_|\__,_/_/   \__,_/_/         
>   Apache Karaf (4.2.1)
> Hit '<tab>' for a list of available commands
> and '[cmd] --help' for help on a specific command.
> Hit '<ctrl-d>' or type 'system:shutdown' or 'logout' to shutdown Karaf.
> karaf@root()> feature:repo-add spring-legacy
> Adding feature url mvn:org.apache.karaf.features/spring-legacy/4.2.1/xml/features
> karaf@root()> feature:install aries-blueprint
> karaf@root()> feature:repo-add activemq
> Adding feature url mvn:org.apache.activemq/activemq-karaf/RELEASE/xml/features
> karaf@root()> feature:install activemq-broker
> org.apache.felix.resolver.reason.ReasonException: Unable to resolve root: missing requirement
[root] osgi.identity; osgi.identity=activemq-broker; type=karaf.feature; version="[5.15.5,5.15.5]";
filter:="(&(osgi.identity=activemq-broker)(type=karaf.feature)(version>=5.15.5)(version<=5.15.5))"
[caused by: Unable to resolve activemq-broker/5.15.5: missing requirement [activemq-broker/5.15.5]
osgi.identity; osgi.identity=activemq; type=karaf.feature; version="[5.15.5,5.15.5]" [caused
by: Unable to resolve activemq/5.15.5: missing requirement [activemq/5.15.5] osgi.identity;
osgi.identity=activemq-karaf; type=osgi.bundle; version="[5.15.5,5.15.5]"; resolution:=mandatory
[caused by: Unable to resolve activemq-karaf/5.15.5: missing requirement [activemq-karaf/5.15.5]
osgi.wiring.package; filter:="(&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.16.0)(!(version>=1.0.0)))"]]]
> 	at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
> 	at org.apache.felix.resolver.ResolverImpl.doResolve(ResolverImpl.java:392)
> 	at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:378)
> 	at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:332)
> 	at org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:257)
> 	at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:388)
> 	at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1025)
> 	at org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$13(FeaturesServiceImpl.java:964)
> 	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
> 	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
> 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
> 	at java.lang.Thread.run(Thread.java:745)
> Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to resolve activemq-broker/5.15.5:
missing requirement [activemq-broker/5.15.5] osgi.identity; osgi.identity=activemq; type=karaf.feature;
version="[5.15.5,5.15.5]" [caused by: Unable to resolve activemq/5.15.5: missing requirement
[activemq/5.15.5] osgi.identity; osgi.identity=activemq-karaf; type=osgi.bundle; version="[5.15.5,5.15.5]";
resolution:=mandatory [caused by: Unable to resolve activemq-karaf/5.15.5: missing requirement
[activemq-karaf/5.15.5] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.16.0)(!(version>=1.0.0)))"]]
> 	at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
> 	... 12 more
> Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to resolve activemq/5.15.5:
missing requirement [activemq/5.15.5] osgi.identity; osgi.identity=activemq-karaf; type=osgi.bundle;
version="[5.15.5,5.15.5]"; resolution:=mandatory [caused by: Unable to resolve activemq-karaf/5.15.5:
missing requirement [activemq-karaf/5.15.5] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.16.0)(!(version>=1.0.0)))"]
> 	at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
> 	... 13 more
> Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to resolve activemq-karaf/5.15.5:
missing requirement [activemq-karaf/5.15.5] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.16.0)(!(version>=1.0.0)))"
> 	at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
> 	... 14 more
> Error executing command: Unable to resolve root: missing requirement [root] osgi.identity;
osgi.identity=activemq-broker; type=karaf.feature; version="[5.15.5,5.15.5]"; filter:="(&(osgi.identity=activemq-broker)(type=karaf.feature)(version>=5.15.5)(version<=5.15.5))"
[caused by: Unable to resolve activemq-broker/5.15.5: missing requirement [activemq-broker/5.15.5]
osgi.identity; osgi.identity=activemq; type=karaf.feature; version="[5.15.5,5.15.5]" [caused
by: Unable to resolve activemq/5.15.5: missing requirement [activemq/5.15.5] osgi.identity;
osgi.identity=activemq-karaf; type=osgi.bundle; version="[5.15.5,5.15.5]"; resolution:=mandatory
[caused by: Unable to resolve activemq-karaf/5.15.5: missing requirement [activemq-karaf/5.15.5]
osgi.wiring.package; filter:="(&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.16.0)(!(version>=1.0.0)))"]]]
> karaf@root()>    
> {code}
> In version 4.1.6 it does work



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message