karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Krüger (JIRA) <j...@apache.org>
Subject [jira] [Commented] (KARAF-5997) Build fails with Java11 because exam 4.13-SNAPSHOT unavailable
Date Fri, 02 Nov 2018 13:37:00 GMT

    [ https://issues.apache.org/jira/browse/KARAF-5997?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16673104#comment-16673104
] 

Martin Krüger commented on KARAF-5997:
--------------------------------------

Don't worry with the snapshot version. I compiled it myself. There is no need for the extra
effort when you plan to release the Pax Exam release in the near future anyway.

What worries my more are the warnings in Karaf mentioning reflection operations which are
not supported in future java versions. But that is something for another ticket and later.

> Build fails with Java11 because exam 4.13-SNAPSHOT unavailable
> --------------------------------------------------------------
>
>                 Key: KARAF-5997
>                 URL: https://issues.apache.org/jira/browse/KARAF-5997
>             Project: Karaf
>          Issue Type: Bug
>            Reporter: Martin Krüger
>            Priority: Major
>
> Build fails with Java11 because exam 4.13-SNAPSHOT unavailable
> I assume the build also fails with Java9+ because the profile switches the property from
4.12 to 4.13-SNAPSHOT for the exam version.
> Please consider what to do in this case because requiring build dependencies which are
not available is problematic. Also building pax-exam fails with Java11 because of various
issues.
> Is there a recommendation what to do? (e.g. report patches to the pax project or just
wait?)



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message