karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lars Kiesow (JIRA)" <j...@apache.org>
Subject [jira] [Created] (KARAF-6004) karaf-maven-plugin:assembly results in ArrayIndexOutOfBoundsException
Date Tue, 06 Nov 2018 12:55:00 GMT
Lars Kiesow created KARAF-6004:
----------------------------------

             Summary: karaf-maven-plugin:assembly results in ArrayIndexOutOfBoundsException
                 Key: KARAF-6004
                 URL: https://issues.apache.org/jira/browse/KARAF-6004
             Project: Karaf
          Issue Type: Bug
    Affects Versions: 4.2.1
            Reporter: Lars Kiesow


Trying to upgrade from Karaf 4.1.6 to Karaf 4.2.1 for a custom assembly results in an ArrayIndexOutOfBoundsException
without any specific information from the karaf-maven-plugin.


The error I get is just:

[ERROR] Failed to execute goal org.apache.karaf.tooling:karaf-maven-plugin:4.2.1:assembly
(default-assembly) on project opencast-dist-develop: Unable to build assembly: -1 -> [Help
1] 
org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.apache.karaf.tooling:karaf-maven-plugin:4.2.1:assembly
(default-assembly) on project opencast-dist-develop: Unable to build asse
mbly [...] Caused by: java.lang.ArrayIndexOutOfBoundsException: -1 [...]


See the attached logs for more details.

 

Updating to 4.2.0 instead works just fine. Hence the problem lies between Karaf 4.2.0 and
4.2.1



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message