karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (Jira) <j...@apache.org>
Subject [jira] [Deleted] (KARAF-6572) class loader policy
Date Fri, 03 Jan 2020 07:49:00 GMT

     [ https://issues.apache.org/jira/browse/KARAF-6572?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jean-Baptiste Onofré deleted KARAF-6572:
----------------------------------------


> class loader policy
> -------------------
>
>                 Key: KARAF-6572
>                 URL: https://issues.apache.org/jira/browse/KARAF-6572
>             Project: Karaf
>          Issue Type: Question
>            Reporter: MORSI JALLOULI
>            Priority: Major
>
> Hello,
>  *Does Karaf have a mechanism for changing the default class loader policy?*   I'm
Looking for something to the effect: "Classes loaded with local class loader first (parent
last)"  
> I've added serializer-2.7.1.jar to My bundle jar to use org/apache/xml/serializer/dom3/LSSerializerImpl
class, but LSSerializerImpl is also found in xml.jar of JRE 8
>  
> when trying to install the bundle, karaf use xml.jar  instead of serializer-2.7.1.jar
!!
>  
> How can i force Karaf to use serializer-2.7.1.jar for LSSerializerImpl  class ?
>  
> Regards,
> Morsi



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message