karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "wenjie sun (Jira)" <j...@apache.org>
Subject [jira] [Created] (KARAF-6781) deployer error when update karaf from 4.2.6 to 4.2.9
Date Tue, 07 Jul 2020 01:16:00 GMT
wenjie sun created KARAF-6781:
---------------------------------

             Summary: deployer error when update karaf from 4.2.6 to 4.2.9
                 Key: KARAF-6781
                 URL: https://issues.apache.org/jira/browse/KARAF-6781
             Project: Karaf
          Issue Type: Dependency upgrade
          Components: karaf
    Affects Versions: 4.2.9
         Environment: karaf 4.2.9:

feature definition:

<feature name="myfeature" version="0.0.1">
 <feature prerequisite="true">wrap</feature>
 <feature prerequisite="true">standard</feature>
 <feature prerequisite="true">jndi</feature>
 <feature prerequisite="true">jpa</feature>
 <feature prerequisite="true">pax-transx-tm-api</feature>
 <feature prerequisite="true">pax-transx-tm-geronimo</feature>
 <feature prerequisite="true">transaction</feature>
 <feature prerequisite="true">openjpa3</feature>
<bundle>mvn:org.postgresql/postgresql/42.2.14</bundle>
 <bundle>mvn:commons-lang/commons-lang/2.6</bundle>
 <bundle>mvn:commons-codec/commons-codec/1.14</bundle>
 <bundle>mvn:org.glassfish.hk2/osgi-resource-locator/1.0.1</bundle>
 <bundle>mvn:javax.xml.bind/jaxb-api/2.3.0</bundle>
<bundle dependency="true">mvn:org.eclipse.persistence/javax.persistence/2.2.0</bundle>
 <bundle dependency="true">mvn:commons-collections/commons-collections/3.2.2</bundle>
 <capability>
 osgi.service;objectClass=javax.sql.DataSource;effective:=active;osgi.jndi.service.name=jdbc/postgres
 </capability>
 </feature>
            Reporter: wenjie sun


after update karaf from 4.2.6 to 4.2.9, when do verify by karaf-maven-plugin, I met following
error:

 

Chain 1:

  org.apache.aries.jpa.container [org.apache.aries.jpa.container/2.7.2]

    import: (&(osgi.wiring.package=javax.persistence)(version>=0.0.0))

     |

    export: osgi.wiring.package: javax.persistence

  javax.persistence [javax.persistence/2.1.0.v201304241213]

 

Chain 2:

  org.apache.aries.jpa.container [org.apache.aries.jpa.container/2.7.2]

    require: (&(osgi.contract=JavaJPA)(|(version=2)(version=2.1))(!(version>=2.2)))

     |

    provide: [org.apache.aries.jpa.javax.persistence_2.1/2.7.2] osgi.contract; osgi.contract=JavaJPA;
version:List<Version>="2.1.0,2.0.0,1.0.0"; uses:="javax.persistence,ja

  org.apache.aries.jpa.javax.persistence_2.1 [org.apache.aries.jpa.javax.persistence_2.1/2.7.2]

    import: (&(osgi.wiring.package=javax.persistence)(version>=0.0.0))

     |

    export: osgi.wiring.package: javax.persistence

  org.apache.aries.jpa.javax.persistence_2.1 [org.apache.aries.jpa.javax.persistence_2.1/2.7.2]

 

 



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message