kudu-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jdcry...@apache.org
Subject [3/4] kudu git commit: [java] Update outdated dependencies
Date Thu, 17 Aug 2017 17:30:58 GMT
[java] Update outdated dependencies

Includes the following version updates:
- Avro 1.8.1 -> 1.8.2
- Flume 1.6.0 -> 1.7.0
- Gradle 4.0.1 -> 4.1.0
- Jepsen 0.1.3 -> 0.1.5
- Many build plugin versions

Also moves and sorts the versions alphabetically.

Change-Id: I38ea098d3c4543916c43ddb76d4e127fee93ece6
Reviewed-on: http://gerrit.cloudera.org:8080/7647
Tested-by: Kudu Jenkins
Reviewed-by: Adar Dembo <adar@cloudera.com>
Reviewed-by: Jean-Daniel Cryans <jdcryans@apache.org>


Project: http://git-wip-us.apache.org/repos/asf/kudu/repo
Commit: http://git-wip-us.apache.org/repos/asf/kudu/commit/f2675b2c
Tree: http://git-wip-us.apache.org/repos/asf/kudu/tree/f2675b2c
Diff: http://git-wip-us.apache.org/repos/asf/kudu/diff/f2675b2c

Branch: refs/heads/master
Commit: f2675b2cd95e74942ebefe1fb95101d812476ce8
Parents: e4c7c81
Author: Grant Henke <granthenke@gmail.com>
Authored: Tue Aug 8 11:08:34 2017 -0500
Committer: Jean-Daniel Cryans <jdcryans@apache.org>
Committed: Thu Aug 17 16:24:55 2017 +0000

----------------------------------------------------------------------
 java/gradle/buildscript.gradle                |  2 +-
 java/gradle/dependencies.gradle               | 10 ++---
 java/gradle/wrapper/gradle-wrapper.properties |  3 +-
 java/gradlew                                  |  2 +-
 java/kudu-flume-sink/pom.xml                  |  5 ---
 java/kudu-jepsen/pom.xml                      |  9 ++---
 java/kudu-spark-tools/pom.xml                 |  2 +-
 java/kudu-spark/pom.xml                       |  4 +-
 java/pom.xml                                  | 43 ++++++++++++++--------
 9 files changed, 42 insertions(+), 38 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/kudu/blob/f2675b2c/java/gradle/buildscript.gradle
----------------------------------------------------------------------
diff --git a/java/gradle/buildscript.gradle b/java/gradle/buildscript.gradle
index 6f062f8..8251d54 100644
--- a/java/gradle/buildscript.gradle
+++ b/java/gradle/buildscript.gradle
@@ -31,7 +31,7 @@ dependencies {
   classpath "com.commercehub.gradle.plugin:gradle-avro-plugin:0.9.0"
   classpath "com.github.ben-manes:gradle-versions-plugin:0.15.0"
   classpath "com.github.jengelman.gradle.plugins:shadow:2.0.1"
-  classpath "com.google.protobuf:protobuf-gradle-plugin:0.8.1"
+  classpath "com.google.protobuf:protobuf-gradle-plugin:0.8.2"
   classpath "com.netflix.nebula:nebula-clojure-plugin:4.1.0"
   classpath "io.spring.gradle:propdeps-plugin:0.0.9.RELEASE"
 }
\ No newline at end of file

http://git-wip-us.apache.org/repos/asf/kudu/blob/f2675b2c/java/gradle/dependencies.gradle
----------------------------------------------------------------------
diff --git a/java/gradle/dependencies.gradle b/java/gradle/dependencies.gradle
index c7bd775..3b54c43 100755
--- a/java/gradle/dependencies.gradle
+++ b/java/gradle/dependencies.gradle
@@ -23,22 +23,22 @@ ext {
   versions = [:]
   libs = [:]
   // All supported scala versions.
-  scalaVersions = propertyWithDefault("scalaVersions", "2.11.8,2.10.6").split(",")
+  scalaVersions = propertyWithDefault("scalaVersions", "2.11.11,2.10.6").split(",")
 }
 
 versions += [
     async          : "1.4.1",
-    avro           : "1.8.1",
+    avro           : "1.8.2",
     clojure        : "1.8.0",
     clojureToolsCli: "0.3.5",
     commonsIo      : "2.5",
     findbugs       : "3.0.1",
-    flume          : "1.6.0",
-    gradle         : "4.0.2",
+    flume          : "1.7.0",
+    gradle         : "4.1.0",
     guava          : "20.0",
     hadoop         : "2.8.1",
     hamcrest       : "1.3",
-    jepsen         : "0.1.3",
+    jepsen         : "0.1.5",
     jsr305         : "3.0.2",
     junit          : "4.12",
     log4j          : "1.2.17",

http://git-wip-us.apache.org/repos/asf/kudu/blob/f2675b2c/java/gradle/wrapper/gradle-wrapper.properties
----------------------------------------------------------------------
diff --git a/java/gradle/wrapper/gradle-wrapper.properties b/java/gradle/wrapper/gradle-wrapper.properties
index fc47300..8edd05c 100644
--- a/java/gradle/wrapper/gradle-wrapper.properties
+++ b/java/gradle/wrapper/gradle-wrapper.properties
@@ -1,6 +1,5 @@
-#Wed Aug 02 23:12:26 CDT 2017
 distributionBase=GRADLE_USER_HOME
 distributionPath=wrapper/dists
 zipStoreBase=GRADLE_USER_HOME
 zipStorePath=wrapper/dists
-distributionUrl=https\://services.gradle.org/distributions/gradle-4.0.2-all.zip
+distributionUrl=https\://services.gradle.org/distributions/gradle-4.1.0-bin.zip

http://git-wip-us.apache.org/repos/asf/kudu/blob/f2675b2c/java/gradlew
----------------------------------------------------------------------
diff --git a/java/gradlew b/java/gradlew
index eae4091..19a088c 100755
--- a/java/gradlew
+++ b/java/gradlew
@@ -66,7 +66,7 @@ esac
 
 
 if [ ! -e $APP_HOME/gradle/wrapper/gradle-wrapper.jar ]; then
-   curl -o $APP_HOME/gradle/wrapper/gradle-wrapper.jar https://raw.githubusercontent.com/gradle/gradle/v4.0.2/gradle/wrapper/gradle-wrapper.jar
+   curl -o $APP_HOME/gradle/wrapper/gradle-wrapper.jar https://raw.githubusercontent.com/gradle/gradle/v4.1.0/gradle/wrapper/gradle-wrapper.jar
 fi
 
 CLASSPATH=$APP_HOME/gradle/wrapper/gradle-wrapper.jar

http://git-wip-us.apache.org/repos/asf/kudu/blob/f2675b2c/java/kudu-flume-sink/pom.xml
----------------------------------------------------------------------
diff --git a/java/kudu-flume-sink/pom.xml b/java/kudu-flume-sink/pom.xml
index 3b47adc..8aaf980 100644
--- a/java/kudu-flume-sink/pom.xml
+++ b/java/kudu-flume-sink/pom.xml
@@ -20,11 +20,6 @@
   <artifactId>kudu-flume-sink</artifactId>
   <name>Kudu Flume NG Sink</name>
 
-  <properties>
-    <avro.version>1.8.1</avro.version>
-    <flume.version>1.6.0</flume.version>
-  </properties>
-
   <build>
     <plugins>
       <plugin>

http://git-wip-us.apache.org/repos/asf/kudu/blob/f2675b2c/java/kudu-jepsen/pom.xml
----------------------------------------------------------------------
diff --git a/java/kudu-jepsen/pom.xml b/java/kudu-jepsen/pom.xml
index 80d703c..d7e879b 100644
--- a/java/kudu-jepsen/pom.xml
+++ b/java/kudu-jepsen/pom.xml
@@ -30,9 +30,6 @@
         <!-- Jepsen tests require specific infrastructure and do not run as part of the
              regular java tests.-->
         <skipTests>true</skipTests>
-        <clojure.version>1.8.0</clojure.version>
-        <jepsen.version>0.1.3</jepsen.version>
-        <clojure.maven.plugin.version>1.7.1</clojure.maven.plugin.version>
         <!-- List of Kudu Master nodes (e.g. "m0" or "m0,m1,m2") -->
         <masterNodes>m0</masterNodes>
         <!-- List of Kudu Tablet Server nodes (e.g. "t0,t1,t2") -->
@@ -70,7 +67,7 @@
         <dependency>
             <groupId>org.clojure</groupId>
             <artifactId>tools.cli</artifactId>
-            <version>0.3.5</version>
+            <version>${clojure.tools.version}</version>
         </dependency>
 
         <dependency>
@@ -110,7 +107,7 @@
             <plugin>
               <groupId>com.theoryinpractise</groupId>
               <artifactId>clojure-maven-plugin</artifactId>
-              <version>${clojure.maven.plugin.version}</version>
+              <version>${clojure-maven-plugin.version}</version>
               <!-- Load maven extensions (like type and packaging handlers) for
                    the clojure maven plugin-->
               <extensions>true</extensions>
@@ -128,7 +125,7 @@
               <!-- Do not run the checkstyle plugin for clojure sources -->
               <groupId>org.apache.maven.plugins</groupId>
               <artifactId>maven-checkstyle-plugin</artifactId>
-              <version>2.17</version>
+              <version>${maven-checkstyle-plugin.version}</version>
               <executions>
                 <execution>
                   <id>validate</id>

http://git-wip-us.apache.org/repos/asf/kudu/blob/f2675b2c/java/kudu-spark-tools/pom.xml
----------------------------------------------------------------------
diff --git a/java/kudu-spark-tools/pom.xml b/java/kudu-spark-tools/pom.xml
index 46b20cd..4932f26 100644
--- a/java/kudu-spark-tools/pom.xml
+++ b/java/kudu-spark-tools/pom.xml
@@ -134,7 +134,7 @@
             <plugin>
                 <groupId>net.alchim31.maven</groupId>
                 <artifactId>scala-maven-plugin</artifactId>
-                <version>3.2.0</version>
+                <version>${scala-maven-plugin.version}</version>
                 <configuration>
                     <charset>${project.build.sourceEncoding}</charset>
                     <scalaVersion>${scala.version}</scalaVersion>

http://git-wip-us.apache.org/repos/asf/kudu/blob/f2675b2c/java/kudu-spark/pom.xml
----------------------------------------------------------------------
diff --git a/java/kudu-spark/pom.xml b/java/kudu-spark/pom.xml
index 7585940..674aefc 100644
--- a/java/kudu-spark/pom.xml
+++ b/java/kudu-spark/pom.xml
@@ -97,7 +97,7 @@
             <plugin>
                 <groupId>net.alchim31.maven</groupId>
                 <artifactId>scala-maven-plugin</artifactId>
-                <version>3.2.0</version>
+                <version>${scala-maven-plugin.version}</version>
                 <configuration>
                     <charset>${project.build.sourceEncoding}</charset>
                     <scalaVersion>${scala.version}</scalaVersion>
@@ -149,7 +149,7 @@
             <plugin>
                 <groupId>org.codehaus.mojo</groupId>
                 <artifactId>build-helper-maven-plugin</artifactId>
-                <version>1.12</version>
+                <version>${build-helper-maven-plugin.version}</version>
                 <executions>
                     <execution>
                         <phase>generate-sources</phase>

http://git-wip-us.apache.org/repos/asf/kudu/blob/f2675b2c/java/pom.xml
----------------------------------------------------------------------
diff --git a/java/pom.xml b/java/pom.xml
index fed039a..f3befea 100644
--- a/java/pom.xml
+++ b/java/pom.xml
@@ -48,39 +48,52 @@
         <project.reporting.outputEncoding>UTF-8</project.reporting.outputEncoding>
 
         <!-- Maven plugins -->
-        <maven-antrun-plugin.version>1.7</maven-antrun-plugin.version>
-        <maven-assembly-plugin.version>2.6</maven-assembly-plugin.version>
-        <maven-enforcer-plugin.version>1.4</maven-enforcer-plugin.version>
+        <build-helper-maven-plugin.version>3.0.0</build-helper-maven-plugin.version>
+        <clojure-maven-plugin.version>1.7.1</clojure-maven-plugin.version>
+        <maven-antrun-plugin.version>1.8</maven-antrun-plugin.version>
+        <maven-assembly-plugin.version>3.0.0</maven-assembly-plugin.version>
+        <maven-checkstyle-plugin.version>2.17</maven-checkstyle-plugin.version>
+        <maven-compiler-plugin.version>3.6.2</maven-compiler-plugin.version>
+        <maven-enforcer-plugin.version>1.4.1</maven-enforcer-plugin.version>
+        <!-- Note: Bumping maven-failsafe-plugin to 2.19+ breaks the integration tests
due to shading issues -->
         <maven-failsafe-plugin.version>2.18</maven-failsafe-plugin.version>
         <maven-os-plugin.version>1.5.0.Final</maven-os-plugin.version>
+        <maven-jar-plugin.version>3.0.2</maven-jar-plugin.version>
+        <maven-javadoc-plugin.version>2.10.4</maven-javadoc-plugin.version>
         <maven-protoc-plugin.version>0.5.0</maven-protoc-plugin.version>
-        <maven-shade-plugin.version>2.4</maven-shade-plugin.version>
-        <maven-surefire-plugin.version>2.18</maven-surefire-plugin.version>
+        <maven-shade-plugin.version>3.0.0</maven-shade-plugin.version>
+        <maven-surefire-plugin.version>2.20</maven-surefire-plugin.version>
+        <scala-maven-plugin.version>3.2.2</scala-maven-plugin.version>
 
         <!-- Library dependencies -->
+        <jepsen.version>0.1.5</jepsen.version>
         <async.version>1.4.1</async.version>
+        <avro.version>1.8.2</avro.version>
+        <clojure.version>1.8.0</clojure.version>
+        <clojure.tools.version>0.3.5</clojure.tools.version>
         <commons-io.version>2.5</commons-io.version>
+        <flume.version>1.7.0</flume.version>
         <guava.version>20.0</guava.version>
         <hadoop.version>2.8.1</hadoop.version>
-        <jsr305.version>3.0.2</jsr305.version>
         <hamcrest-core.version>1.3</hamcrest-core.version>
+        <jsr305.version>3.0.2</jsr305.version>
         <junit.version>4.12</junit.version>
         <log4j.version>1.2.17</log4j.version>
         <mockito-core.version>2.8.47</mockito-core.version>
         <murmur.version>1.0.0</murmur.version>
         <netty.version>3.10.6.Final</netty.version>
+        <parquet.version>1.9.0</parquet.version>
         <protobuf.version>3.3.0</protobuf.version>
         <slf4j.version>1.7.25</slf4j.version>
-        <yetus.version>0.4.0</yetus.version>
-        <parquet.version>1.9.0</parquet.version>
         <sparkavro.version>3.2.0</sparkavro.version>
+        <yetus.version>0.4.0</yetus.version>
 
         <!-- Scala Library dependencies -->
-        <spark1.version>1.6.3</spark1.version>
-        <spark2.version>2.1.1</spark2.version>
         <scala-2.10.version>2.10.6</scala-2.10.version>
-        <scala-2.11.version>2.11.8</scala-2.11.version>
+        <scala-2.11.version>2.11.11</scala-2.11.version>
         <scalatest.version>3.0.3</scalatest.version>
+        <spark1.version>1.6.3</spark1.version>
+        <spark2.version>2.1.1</spark2.version>
 
         <!-- Misc variables -->
         <testdata.dir>target/testdata</testdata.dir>
@@ -218,7 +231,7 @@
             <plugin>
                 <groupId>org.apache.maven.plugins</groupId>
                 <artifactId>maven-compiler-plugin</artifactId>
-                <version>2.3.2</version>
+                <version>${maven-compiler-plugin.version}</version>
                 <configuration>
                     <source>1.7</source>
                     <target>1.7</target>
@@ -227,7 +240,7 @@
             <plugin>
                 <groupId>org.apache.maven.plugins</groupId>
                 <artifactId>maven-jar-plugin</artifactId>
-                <version>2.3.2</version>
+                <version>${maven-jar-plugin.version}</version>
                 <executions>
                     <execution>
                         <phase>prepare-package</phase>
@@ -259,7 +272,7 @@
             <plugin>
                 <groupId>org.apache.maven.plugins</groupId>
                 <artifactId>maven-javadoc-plugin</artifactId>
-                <version>2.10.3</version>
+                <version>${maven-javadoc-plugin.version}</version>
                 <configuration>
                     <maxmemory>2048m</maxmemory>
                     <notimestamp>true</notimestamp>
@@ -282,7 +295,7 @@
             <plugin>
                 <groupId>org.apache.maven.plugins</groupId>
                 <artifactId>maven-checkstyle-plugin</artifactId>
-                <version>2.17</version>
+                <version>${maven-checkstyle-plugin.version}</version>
                 <dependencies>
                     <dependency>
                         <groupId>com.puppycrawl.tools</groupId>


Mime
View raw message