kudu-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From granthe...@apache.org
Subject [6/6] kudu git commit: [Java] Upgrade Dependencies
Date Tue, 02 Oct 2018 19:01:57 GMT
[Java] Upgrade Dependencies

Upgrades the Java dependencies and Gradle versions.

Minor version upgrades:
- Mockito 2.21.0 -> 2.22.0
- Yetus 0.7.0 -> 0.8.0

Maintenance version upgrades:
- Hadoop 3.1.0 -> 3.1.1
- Spark 2.3.1 -> 2.3.2

Gradle upgrades:
- Gradle 4.9.0 -> 4.10.2
- gradle-avro-plugin 0.14.2 -> 0.15.1
- nebula-clojure-plugin 5.1.0 -> 6.0.2
- spotbugs-gradle-plugin 1.6.2 -> 1.6.4
- gradle-animalsniffer-plugin 1.4.5 -> 1.4.6
- gradle-scalafmt 1.6.0 -> 1.7.0

Change-Id: Ib087e3b8ede9fe1bdd0cea7988211cefd137e707
Reviewed-on: http://gerrit.cloudera.org:8080/11541
Reviewed-by: Adar Dembo <adar@cloudera.com>
Tested-by: Kudu Jenkins


Project: http://git-wip-us.apache.org/repos/asf/kudu/repo
Commit: http://git-wip-us.apache.org/repos/asf/kudu/commit/8513685b
Tree: http://git-wip-us.apache.org/repos/asf/kudu/tree/8513685b
Diff: http://git-wip-us.apache.org/repos/asf/kudu/diff/8513685b

Branch: refs/heads/master
Commit: 8513685babb1b4a055af4222d990948a48e1aae7
Parents: 545afa7
Author: Grant Henke <granthenke@apache.org>
Authored: Fri Sep 28 11:42:28 2018 -0700
Committer: Grant Henke <granthenke@apache.org>
Committed: Tue Oct 2 19:01:30 2018 +0000

----------------------------------------------------------------------
 java/buildSrc/build.gradle                    | 10 +++++-----
 java/gradle/dependencies.gradle               | 10 +++++-----
 java/gradle/wrapper/gradle-wrapper.properties |  2 +-
 java/gradlew                                  |  2 +-
 java/pom.xml                                  |  8 ++++----
 5 files changed, 16 insertions(+), 16 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/kudu/blob/8513685b/java/buildSrc/build.gradle
----------------------------------------------------------------------
diff --git a/java/buildSrc/build.gradle b/java/buildSrc/build.gradle
index a88ebcc..f02633f 100644
--- a/java/buildSrc/build.gradle
+++ b/java/buildSrc/build.gradle
@@ -28,15 +28,15 @@ repositories {
 // Manage plugin dependencies since the plugin block can't be used in included build scripts
yet.
 // For more details see: https://docs.gradle.org/current/userguide/plugins.html#plugins_dsl_limitations
 dependencies {
-  compile "com.commercehub.gradle.plugin:gradle-avro-plugin:0.14.2"
+  compile "com.commercehub.gradle.plugin:gradle-avro-plugin:0.15.1"
   compile "com.github.ben-manes:gradle-versions-plugin:0.20.0"
   compile "com.github.jengelman.gradle.plugins:shadow:2.0.4"
   compile "com.google.protobuf:protobuf-gradle-plugin:0.8.6"
-  compile "com.netflix.nebula:nebula-clojure-plugin:5.1.0"
-  compile "gradle.plugin.com.github.spotbugs:spotbugs-gradle-plugin:1.6.2"
+  compile "com.netflix.nebula:nebula-clojure-plugin:6.0.2"
+  compile "gradle.plugin.com.github.spotbugs:spotbugs-gradle-plugin:1.6.4"
   compile "io.spring.gradle:propdeps-plugin:0.0.9.RELEASE"
   compile "net.ltgt.gradle:gradle-errorprone-plugin:0.0.16"
-  compile "ru.vyarus:gradle-animalsniffer-plugin:1.4.5"
+  compile "ru.vyarus:gradle-animalsniffer-plugin:1.4.6"
   compile 'com.google.code.gson:gson:2.8.5'
-  compile "cz.alenkacz:gradle-scalafmt:1.6.0"
+  compile "cz.alenkacz:gradle-scalafmt:1.7.0"
 }

http://git-wip-us.apache.org/repos/asf/kudu/blob/8513685b/java/gradle/dependencies.gradle
----------------------------------------------------------------------
diff --git a/java/gradle/dependencies.gradle b/java/gradle/dependencies.gradle
index 252769a..267e452 100755
--- a/java/gradle/dependencies.gradle
+++ b/java/gradle/dependencies.gradle
@@ -32,18 +32,18 @@ versions += [
     commonsIo      : "2.6",
     errorprone     : "2.3.1",
     flume          : "1.8.0",
-    gradle         : "4.9",
+    gradle         : "4.10.2",
     // We use the android version instead of the jre version
     // to maintain Java 1.7 compatibility.
     guava          : "26.0-android",
-    hadoop         : "3.1.0",
+    hadoop         : "3.1.1",
     hamcrest       : "1.3",
     hive           : "2.3.3",
     jepsen         : "0.1.5",
     jsr305         : "3.0.2",
     junit          : "4.12",
     log4j          : "1.2.17",
-    mockito        : "2.21.0",
+    mockito        : "2.22.0",
     murmur         : "1.0.0",
     netty          : "3.10.6.Final",
     parquet        : "1.10.0",
@@ -53,10 +53,10 @@ versions += [
     scalatest      : "3.0.5",
     scopt          : "3.7.0",
     slf4j          : "1.7.25",
-    spark          : "2.3.1",
+    spark          : "2.3.2",
     sparkAvro      : "4.0.0",
     spotBugs       : "3.1.6",
-    yetus          : "0.7.0"
+    yetus          : "0.8.0"
 ]
 
 // Log the Gradle version used vs defined.

http://git-wip-us.apache.org/repos/asf/kudu/blob/8513685b/java/gradle/wrapper/gradle-wrapper.properties
----------------------------------------------------------------------
diff --git a/java/gradle/wrapper/gradle-wrapper.properties b/java/gradle/wrapper/gradle-wrapper.properties
index 20b10aa..507a527 100644
--- a/java/gradle/wrapper/gradle-wrapper.properties
+++ b/java/gradle/wrapper/gradle-wrapper.properties
@@ -14,6 +14,6 @@
 # limitations under the License.
 distributionBase=GRADLE_USER_HOME
 distributionPath=wrapper/dists
-distributionUrl=https\://services.gradle.org/distributions/gradle-4.9-all.zip
+distributionUrl=https\://services.gradle.org/distributions/gradle-4.10.2-all.zip
 zipStoreBase=GRADLE_USER_HOME
 zipStorePath=wrapper/dists

http://git-wip-us.apache.org/repos/asf/kudu/blob/8513685b/java/gradlew
----------------------------------------------------------------------
diff --git a/java/gradlew b/java/gradlew
index f40bb25..47787ba 100755
--- a/java/gradlew
+++ b/java/gradlew
@@ -82,7 +82,7 @@ esac
 # Loop in case we encounter an error.
 for attempt in 1 2 3; do
   if [ ! -e $APP_HOME/gradle/wrapper/gradle-wrapper.jar ]; then
-    if ! curl -s -S --retry 3 -L -o "$APP_HOME/gradle/wrapper/gradle-wrapper.jar" "https://raw.githubusercontent.com/gradle/gradle/v4.9.0/gradle/wrapper/gradle-wrapper.jar";
then
+    if ! curl -s -S --retry 3 -L -o "$APP_HOME/gradle/wrapper/gradle-wrapper.jar" "https://raw.githubusercontent.com/gradle/gradle/v4.10.2/gradle/wrapper/gradle-wrapper.jar";
then
       rm -f "$APP_HOME/gradle/wrapper/gradle-wrapper.jar"
       # Pause for a bit before looping in case the server throttled us.
       sleep 5

http://git-wip-us.apache.org/repos/asf/kudu/blob/8513685b/java/pom.xml
----------------------------------------------------------------------
diff --git a/java/pom.xml b/java/pom.xml
index cb3fdc9..1aaba72 100644
--- a/java/pom.xml
+++ b/java/pom.xml
@@ -73,14 +73,14 @@
         <flume.version>1.8.0</flume.version>
 
         <guava.version>26.0-android</guava.version>
-        <hadoop.version>3.1.0</hadoop.version>
+        <hadoop.version>3.1.1</hadoop.version>
         <hamcrest-core.version>1.3</hamcrest-core.version>
         <hive.version>2.3.3</hive.version>
         <jepsen.version>0.1.5</jepsen.version>
         <jsr305.version>3.0.2</jsr305.version>
         <junit.version>4.12</junit.version>
         <log4j.version>1.2.17</log4j.version>
-        <mockito-core.version>2.21.0</mockito-core.version>
+        <mockito-core.version>2.22.0</mockito-core.version>
         <murmur.version>1.0.0</murmur.version>
         <netty.version>3.10.6.Final</netty.version>
         <parquet.version>1.10.0</parquet.version>
@@ -88,13 +88,13 @@
         <scopt.version>3.7.0</scopt.version>
         <slf4j.version>1.7.25</slf4j.version>
         <sparkavro.version>4.0.0</sparkavro.version>
-        <yetus.version>0.7.0</yetus.version>
+        <yetus.version>0.8.0</yetus.version>
 
         <!-- Scala Library dependencies -->
         <scala.binary.version>2.11</scala.binary.version>
         <scala.version>2.11.12</scala.version>
         <scalatest.version>3.0.5</scalatest.version>
-        <spark.version>2.3.1</spark.version>
+        <spark.version>2.3.2</spark.version>
         <spark.version.label>spark2</spark.version.label>
 
         <!-- Misc variables -->


Mime
View raw message