kudu-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From granthe...@apache.org
Subject [kudu] 01/02: [docs] Pin the bundler install to 1.17.3
Date Tue, 09 Jul 2019 17:38:59 GMT
This is an automated email from the ASF dual-hosted git repository.

granthenke pushed a commit to branch branch-1.10.x
in repository https://gitbox.apache.org/repos/asf/kudu.git

commit be8534055c7dad16b2bfe6b7f81ac62b51d279e0
Author: Grant Henke <granthenke@apache.org>
AuthorDate: Tue Jul 9 10:38:05 2019 -0500

    [docs] Pin the bundler install to 1.17.3
    
    The bundler install is pinned to an explicit version because
    versions after 2.0.0 require ruby >= 2.3.0 which is not
    available on many supported operating systems.
    
    Change-Id: Iafbcd31c28a9c8b2444bf83b99dc97882f8c2b5d
    Reviewed-on: http://gerrit.cloudera.org:8080/13824
    Tested-by: Kudu Jenkins
    Reviewed-by: Andrew Wong <awong@cloudera.com>
    (cherry picked from commit b612181916be426b18e5cc5490ac1a2d23355936)
    Reviewed-on: http://gerrit.cloudera.org:8080/13826
---
 docs/support/scripts/make_docs.sh | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

diff --git a/docs/support/scripts/make_docs.sh b/docs/support/scripts/make_docs.sh
index 1033c5f..b9837ba 100755
--- a/docs/support/scripts/make_docs.sh
+++ b/docs/support/scripts/make_docs.sh
@@ -103,7 +103,10 @@ BUNDLE="$GEM_PATH/bin/bundle"
 echo "Locally installing ruby gems needed to build docs."
 if [ ! -x "$BUNDLE" ]; then
   set -x
-  gem install --no-ri --no-rdoc -q --install-dir "$GEM_PATH" bundler
+  # The bundler install is pinned to an explicit version because versions after
+  # 2.0.0 require ruby >= 2.3.0 which is not available on many supported
+  # operating systems.
+  gem install --no-ri --no-rdoc -q --install-dir "$GEM_PATH" bundler -v '1.17.3'
   set +x
 fi
 


Mime
View raw message