kudu-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Darren Hoo <darren....@gmail.com>
Subject Re: DROP Table in KUDU
Date Wed, 22 Jun 2016 11:45:04 GMT
there's already an issue tracking this:

https://issues.cloudera.org/browse/IMPALA-3424


On Wed, Jun 22, 2016 at 7:14 PM, Ajai Omtri <ajai.omtri@gmail.com> wrote:

> Thank you. Was able to delete it by below command:
>
>
>
> kudu-admin -master_addresses <Kudu-Master-hostname> delete_table
> <table-name>
>
>
>
> Wondering is this an expected behavior that regular impala and the Kudu
> Impala are not in sync?
>
>
>
>
>
>
>
> *From:* Darren Hoo [mailto:darren.hoo@gmail.com]
> *Sent:* Tuesday, June 21, 2016 10:13 PM
> *To:* user@kudu.incubator.apache.org
> *Subject:* Re: DROP Table in KUDU
>
>
>
> Hi,
>
>
>
> you can use kudu-admin to delete tables in kudu then try create again in
> impala.
>
>
>
> On Wed, Jun 22, 2016 at 10:01 AM, Ajai Omtri <ajai.omtri@gmail.com> wrote:
>
> Hi,
>
>
>
> I have create a table in KUDU Impala session and then dropped that table
> from the regular Impala session.
>
>
>
> Now when I say “show tables” I don’t see the table in both the sessions
> but I can’t re-create the table as KUDU thinks the table still exists. Any
> idea how to fix this please?
>
>
>
> I also see the table present in the KUDU webUI.
>
>
>
> Below is the error message that I get from KUDU – Impala session:
>
>
>
> Table “XXX” already exists in Kudu master xxxxxx:7051
>
>
>
> Thanks,
>
> Ajai Omtri
>
>
>

Mime
View raw message