lens-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pranav Kumar Agarwal <praag...@gmail.com>
Subject Re: Unable to run TestHiveDriver tests on latest code
Date Mon, 29 Jun 2015 15:18:17 GMT
My apologies for the noise created about this. It's still not clear what 
really happened however when I started to observe that basic ps -ef 
output started to differ across terminals I restarted the machine and 
thereafter everything working like a charm.

Thanks for all the prompt feedback. Much appreciated.

Regards,
-Pranav.
p.s. /tmp had good space available

On 29/06/15 9:53 am, amareshwarisr . wrote:
> Pranav,
>
> Is JAVA_HOME environment variable set? HiveDriver tests required 
> JAVA_HOME to be set.
>
> Also, Can you look at querylogs by running following in 
> lens-driver-hive module?
>  target/query_logs/*/* |less
>
> Also, is your /tmp is fine? Some of the tests use /tmp to put tables 
> and their data.
>
> Thanks
> Amareshwari
>
> On Mon, Jun 29, 2015 at 1:43 AM, Yash Sharma <yash360@gmail.com 
> <mailto:yash360@gmail.com>> wrote:
>
>     Hey Pranav,
>     Could you also share your OS details. There are coupe of
>     intermittent issues with windows.
>     I am able to build on my local setup. I am on Ubuntu 14 Java 7 Mvn
>     3.0+ and able to build it.
>
>     Please share the error stack you faced while building the tests.
>     Also do consider exploring/contributing back in case you gather
>     sufficient information about the issue.We would love to see your
>     contributions.
>
>     Best,
>     Yash
>
>     On Sun, Jun 28, 2015 at 11:21 PM, Pranav Kumar Agarwal
>     <praagarw@gmail.com <mailto:praagarw@gmail.com>> wrote:
>
>         Hi Yash,
>
>         Thanks for your prompt response.
>
>         I was able to see that 404 is coming from
>         QueryExecutionServiceImpl.getResultSet method. In that method
>         ctx is null and the query handle isn't yet stored in
>         finished_queries table hence the NotFoundException is raised.
>         I can run other commands like show cubes etc. I don't think
>         its a connection issue.
>
>         All the queries are running well from inmobi's hive cli.
>
>         I'm using Java 1.7 and maven 3.21. I was able to run Lens with
>         the same tools earlier.
>
>         Regards,
>         -Pranav.
>
>
>         On 28/06/15 9:48 pm, Yash Sharma wrote:
>>
>>         Also mention ur env details and java/maven versions.
>>         Would be helpful for us to debug.
>>
>>         Thanks
>>
>>         - Via mobile. Excuse brevity.
>>
>>         On 28 Jun 2015 9:46 pm, "Yash Sharma" <yash360@gmail.com
>>         <mailto:yash360@gmail.com>> wrote:
>>
>>             Hi Pranav,
>>             The error does not highlight a lot of info about your
>>             error but i believe that a 404 might be a connection issue.
>>
>>             Can u check if u can access hive directly (inmobi's
>>             version of hive). The root cause can be identified by the
>>             testcase u mentioned. I feel it might be related.
>>
>>             Could you share more info or error logs. Lets figure out
>>             the root cause if it helps.
>>
>>             Regards
>>
>>             - Via mobile. Excuse brevity.
>>
>>             On 28 Jun 2015 9:26 pm, "Pranav Kumar Agarwal"
>>             <praagarw@gmail.com <mailto:praagarw@gmail.com>> wrote:
>>
>>                 Hi Lens Gurus,
>>
>>                 I installed lens from latest and found that tests are
>>                 failing:
>>                 Running TestSuite
>>                 Tests run: 31, *Failures: 21*, Errors: 0, Skipped: 0,
>>                 Time elapsed: 41.213 sec <<< FAILURE! - in TestSuite
>>                 testExecuteQuery(org.apache.lens.driver.hive.TestHiveDriver)
>>                 Time elapsed: 1.068 sec <<< FAILURE!
>>
>>                 I'm getting following error from CLI
>>
>>                 lens-shell>query execute select * from local_fact1
>>                 28 Jun 2015 20:14:12,586 [Spring Shell] INFO
>>                 cliLogger  - Query handle:
>>                 34eb78db-6f47-4079-841e-bf6f7a6e0b1e
>>                 28 Jun 2015 20:14:17,854 [Spring Shell] INFO
>>                 cliLogger  - User query: 'select * from local_fact1'
>>                 was submitted to org.apache.lens.driver.hive.HiveDriver
>>                 28 Jun 2015 20:14:17,855 [Spring Shell] INFO
>>                 cliLogger  -  Driver query: 'select * from
>>                 local_fact1' and Driver handle: OperationHandle
>>                 [opType=EXECUTE_STATEMENT,
>>                 getHandleIdentifier()=8f489ef6-068f-4333-ba83-8333bea499f9]
>>                 *Command failed java.lang.IllegalStateException:
>>                 Failed to get resultset metadata, cause:HTTP 404 Not
>>                 Found*
>>                 lens-shell>query execute select * from local_fact1
>>                 28 Jun 2015 20:14:25,233 [Spring Shell] INFO
>>                 cliLogger  - Query handle:
>>                 1f59bc58-9272-4a95-8f95-cb3ad9225d69
>>                 28 Jun 2015 20:14:26,211 [Spring Shell] INFO
>>                 cliLogger  - User query: 'select * from local_fact1'
>>                 was submitted to org.apache.lens.driver.hive.HiveDriver
>>                 28 Jun 2015 20:14:26,212 [Spring Shell] INFO
>>                 cliLogger  -  Driver query: 'select * from
>>                 local_fact1' and Driver handle: OperationHandle
>>                 [opType=EXECUTE_STATEMENT,
>>                 getHandleIdentifier()=4f1f8c9a-a9b3-4556-a2ba-b9ad3a8823b5]
>>                 *0 rows process in (0) seconds.*
>>
>>                 There are 2 issues
>>                 a) I intermittently get the result metadata failed
>>                 with HTTP 404
>>                 b) 0 rows returned.
>>
>>                 For each query fired via Lens I can see map reduce
>>                 job getting initiated but the results for *all*
>>                 queries is always 0 rows processed.
>>
>>                 Is this a known issue?
>>
>>                 Regards,
>>                 -Pranav.
>>
>
>
>


Mime
View raw message