lens-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "amareshwarisr ." <amareshw...@gmail.com>
Subject Re: Unable to start the Lens server
Date Mon, 15 Jun 2015 10:33:32 GMT
Hello Sneh,

Thanks for reaching out. Lens depends on a forked version of Hive as of now.

Please see
http://lens.incubator.apache.org/lenshome/install-and-run.html#Installing_and_Running_Lens
and
http://lens.incubator.apache.org/developer/contribute.html#Building_Hive_from_Source
for how to build from forked hive.

Thanks
Amareshwari


On Mon, Jun 15, 2015 at 3:55 PM, Sneh <shanker.sneh@myntra.com> wrote:

> Hello all,
>
> I am trying my hands on Lens. So need your help with this.
>
> I have HDFS & hive running on my local (Mac OS) in stand alone mode.
>
> I have my lens-site.xml as:
> <property>
>   <name>lens.server.base.url</name>
>   <value>localhost:9999/lensapi/</value>
> </property>
>
> <property>
>   <name>lens.server.drivers</name>
>
> <value>org.apache.lens.driver.hive.HiveDriver,org.apache.lens.driver.jdbc.JDBCDriver</value>
> </property>
>
> <property>
>   <name>lens.server.database.resource.dir</name>
>   <value>/tmp/lens/resources</value>
> </property>
>
> When I do a lens-ctl start, I get the message "Started lens server!".
> But the browser doesn't open the URL localhost:9999/lensapi/
>
> I am sure I am missing something very important, but unable to figure out
> what.
> So didn't try starting the client as the server URL isn't working for me.
>
> Server log says:
> Exception in thread "main" java.lang.NoSuchFieldError:
> HIVE_SESSION_IMPL_CLASSNAME
> at org.apache.lens.server.LensServices.init(LensServices.java:146)
> at org.apache.lens.server.LensServer.startServices(LensServer.java:133)
> at org.apache.lens.server.LensServer.<init>(LensServer.java:87)
> at org.apache.lens.server.LensServer.createLensServer(LensServer.java:76)
> at org.apache.lens.server.LensServer.main(LensServer.java:186)
>
> It might have something to do with hive.
> My hive-site.xml says:
> <property>
>   <name>fs.default.name</name>
>   <value>hdfs://localhost:8088</value>
> </property>
>
> <property>
>   <name>mapred.job.tracker</name>
>   <value>localhost:8021</value>
> </property>
>
> <property>
>     <name>hive.metastore.local</name>
>     <value>TRUE</value>
>    </property>
>
> <property>
> <name>javax.jdo.option.ConnectionURL</name>
>
> <value>jdbc:derby:;databaseName=/Users/shanker.sneh/hive/metastore_db;create=true</value>
> </property>
>
> Sorry for the trivial question apparently.
> Also please point out any prerequisite step which I am missing.
>
> BR,
> *Sneh*
> Engineering BI
>
>
>
>
>

Mime
View raw message