lens-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yash Sharma <yash...@gmail.com>
Subject Re: Unable to run TestHiveDriver tests on latest code
Date Sun, 28 Jun 2015 16:16:32 GMT
Hi Pranav,
The error does not highlight a lot of info about your error but i believe
that a 404 might be a connection issue.

Can u check if u can access hive directly (inmobi's version of hive). The
root cause can be identified by the testcase u mentioned. I feel it might
be related.

Could you share more info or error logs. Lets figure out the root cause if
it helps.

Regards

- Via mobile. Excuse brevity.
On 28 Jun 2015 9:26 pm, "Pranav Kumar Agarwal" <praagarw@gmail.com> wrote:

>  Hi Lens Gurus,
>
> I installed lens from latest and found that tests are failing:
> Running TestSuite
> Tests run: 31, *Failures: 21*, Errors: 0, Skipped: 0, Time elapsed:
> 41.213 sec <<< FAILURE! - in TestSuite
> testExecuteQuery(org.apache.lens.driver.hive.TestHiveDriver)  Time
> elapsed: 1.068 sec  <<< FAILURE!
>
> I'm getting following error from CLI
>
> lens-shell>query execute select * from local_fact1
> 28 Jun 2015 20:14:12,586 [Spring Shell] INFO  cliLogger  - Query handle:
> 34eb78db-6f47-4079-841e-bf6f7a6e0b1e
> 28 Jun 2015 20:14:17,854 [Spring Shell] INFO  cliLogger  - User query:
> 'select * from local_fact1' was submitted to
> org.apache.lens.driver.hive.HiveDriver
> 28 Jun 2015 20:14:17,855 [Spring Shell] INFO  cliLogger  -  Driver query:
> 'select * from local_fact1' and Driver handle: OperationHandle
> [opType=EXECUTE_STATEMENT,
> getHandleIdentifier()=8f489ef6-068f-4333-ba83-8333bea499f9]
> *Command failed java.lang.IllegalStateException: Failed to get resultset
> metadata, cause:HTTP 404 Not Found*
> lens-shell>query execute select * from local_fact1
> 28 Jun 2015 20:14:25,233 [Spring Shell] INFO  cliLogger  - Query handle:
> 1f59bc58-9272-4a95-8f95-cb3ad9225d69
> 28 Jun 2015 20:14:26,211 [Spring Shell] INFO  cliLogger  - User query:
> 'select * from local_fact1' was submitted to
> org.apache.lens.driver.hive.HiveDriver
> 28 Jun 2015 20:14:26,212 [Spring Shell] INFO  cliLogger  -  Driver query:
> 'select * from local_fact1' and Driver handle: OperationHandle
> [opType=EXECUTE_STATEMENT,
> getHandleIdentifier()=4f1f8c9a-a9b3-4556-a2ba-b9ad3a8823b5]
> *0 rows process in (0) seconds.*
>
> There are 2 issues
> a) I intermittently get the result metadata failed with HTTP 404
> b) 0 rows returned.
>
> For each query fired via Lens I can see map reduce job getting initiated
> but the results for *all* queries is always 0 rows processed.
>
> Is this a known issue?
>
> Regards,
> -Pranav.
>

Mime
View raw message