lens-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sneh <shanker.s...@myntra.com>
Subject Re: Unable to start the Lens server
Date Tue, 16 Jun 2015 04:58:56 GMT
I tried going a level up & also passed --conf. But getting the same error.

I did not modify the lens-env.sh file; and my lens-client-site.xml is as
basic as:
<configuration>
       <property>
    <name>lens.server.base.url</name>
    <value>localhost:9999/lensapi/</value>
  </property>

  <property>
    <name>lens.client.dbname</name>
    <value>default</value>
  </property>

  <property>
    <name>lens.client.user.name</name>
    <value>anonymous</value>
  </property>
  </configuration>

BR,
*Sneh*
Engineering BI

On Tue, Jun 16, 2015 at 10:10 AM, amareshwarisr . <amareshwari@gmail.com>
wrote:

> Sneh,
>
> Did you pass your own client config? Seems the url passed is wrong or not
> there. The client distribution comes with conf/ directory with default conf
> and bin/ with lens-cli.sh.
>
> Can you try launching cli from one level up? i.e. *bin/lens-cli.sh* to
> pick default conf directory.
>
> or "*sh lens-cli.sh --conf ../conf* " would also work.
>
> Thanks
> Amareshwari
>
> On Mon, Jun 15, 2015 at 11:11 PM, Sneh <shanker.sneh@myntra.com> wrote:
>
>> Dear team,
>>
>> I see the server running but the client isn't starting.
>> It's throwing the following error:
>>
>> EN-ShankerS:bin shanker.sneh$ sh lens-cli.sh
>>
>> Exception in thread "main"
>> org.springframework.beans.factory.BeanCreationException: Error creating
>> bean with name 'lensConnectionCommands' defined in URL
>> [jar:file:/Users/shanker.sneh/Downloads/apache-lens-2.1.0-beta-incubating-bin/client/lib/lens-cli-2.1.0-beta-incubating.jar!/META-INF/spring/spring-shell-plugin.xml]:
>> Instantiation of bean failed; nested exception is
>> org.springframework.beans.BeanInstantiationException: Could not instantiate
>> bean class [org.apache.lens.cli.commands.LensConnectionCommands]:
>> Constructor threw exception; nested exception is
>> java.lang.ExceptionInInitializerError
>>
>> at
>> org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.instantiateBean(AbstractAutowireCapableBeanFactory.java:997)
>>
>> at
>> org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBeanInstance(AbstractAutowireCapableBeanFactory.java:943)
>>
>> at
>> org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:485)
>>
>> at
>> org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:456)
>>
>> at
>> org.springframework.beans.factory.support.AbstractBeanFactory$1.getObject(AbstractBeanFactory.java:294)
>>
>> at
>> org.springframework.beans.factory.support.DefaultSingletonBeanRegistry.getSingleton(DefaultSingletonBeanRegistry.java:225)
>>
>> at
>> org.springframework.beans.factory.support.AbstractBeanFactory.doGetBean(AbstractBeanFactory.java:291)
>>
>> at
>> org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:193)
>>
>> at
>> org.springframework.beans.factory.support.DefaultListableBeanFactory.preInstantiateSingletons(DefaultListableBeanFactory.java:609)
>>
>> at
>> org.springframework.context.support.AbstractApplicationContext.finishBeanFactoryInitialization(AbstractApplicationContext.java:918)
>>
>> at
>> org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:469)
>>
>> at
>> org.springframework.context.support.ClassPathXmlApplicationContext.<init>(ClassPathXmlApplicationContext.java:139)
>>
>> at
>> org.springframework.shell.Bootstrap.initPluginApplicationContext(Bootstrap.java:131)
>>
>> at
>> org.springframework.shell.Bootstrap.createApplicationContext(Bootstrap.java:120)
>>
>> at org.springframework.shell.Bootstrap.<init>(Bootstrap.java:73)
>>
>> at org.springframework.shell.Bootstrap.main(Bootstrap.java:60)
>>
>> Caused by: org.springframework.beans.BeanInstantiationException: Could
>> not instantiate bean class
>> [org.apache.lens.cli.commands.LensConnectionCommands]: Constructor threw
>> exception; nested exception is java.lang.ExceptionInInitializerError
>>
>> at
>> org.springframework.beans.BeanUtils.instantiateClass(BeanUtils.java:162)
>>
>> at
>> org.springframework.beans.factory.support.SimpleInstantiationStrategy.instantiate(SimpleInstantiationStrategy.java:76)
>>
>> at
>> org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.instantiateBean(AbstractAutowireCapableBeanFactory.java:990)
>>
>> ... 15 more
>>
>> Caused by: java.lang.ExceptionInInitializerError
>>
>> at
>> org.apache.lens.client.LensClientSingletonWrapper.instance(LensClientSingletonWrapper.java:37)
>>
>> at
>> org.apache.lens.cli.commands.BaseLensCommand.getClientWrapper(BaseLensCommand.java:124)
>>
>> at
>> org.apache.lens.cli.commands.BaseLensCommand.getClient(BaseLensCommand.java:120)
>>
>> at
>> org.apache.lens.cli.commands.BaseLensCommand.<init>(BaseLensCommand.java:92)
>>
>> at
>> org.apache.lens.cli.commands.LensConnectionCommands.<init>(LensConnectionCommands.java:37)
>>
>> at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
>>
>> at
>> sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
>>
>> at
>> sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
>>
>> at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
>>
>> at
>> org.springframework.beans.BeanUtils.instantiateClass(BeanUtils.java:147)
>>
>> ... 17 more
>>
>> Caused by: java.lang.IllegalArgumentException: Schema specific part is
>> opaque.
>>
>> at
>> org.glassfish.jersey.uri.internal.JerseyUriBuilder.checkSsp(JerseyUriBuilder.java:693)
>>
>> at
>> org.glassfish.jersey.uri.internal.JerseyUriBuilder.path(JerseyUriBuilder.java:344)
>>
>> at
>> org.glassfish.jersey.uri.internal.JerseyUriBuilder.path(JerseyUriBuilder.java:71)
>>
>> at
>> org.glassfish.jersey.client.JerseyWebTarget.path(JerseyWebTarget.java:156)
>>
>> at
>> org.glassfish.jersey.client.JerseyWebTarget.path(JerseyWebTarget.java:60)
>>
>> at
>> org.apache.lens.client.LensConnection.getSessionWebTarget(LensConnection.java:102)
>>
>> at
>> org.apache.lens.client.LensConnection.getSessionWebTarget(LensConnection.java:117)
>>
>> at org.apache.lens.client.LensConnection.open(LensConnection.java:133)
>>
>> at
>> org.apache.lens.client.LensClient.connectToLensServer(LensClient.java:195)
>>
>> at org.apache.lens.client.LensClient.<init>(LensClient.java:65)
>>
>> at org.apache.lens.client.LensClient.<init>(LensClient.java:51)
>>
>> at org.apache.lens.client.LensClient.<init>(LensClient.java:47)
>>
>> at
>> org.apache.lens.client.LensClientSingletonWrapper.<init>(LensClientSingletonWrapper.java:54)
>>
>> at
>> org.apache.lens.client.LensClientSingletonWrapper$InstanceHolder.<clinit>(LensClientSingletonWrapper.java:33)
>>
>> BR,
>> *Sneh*
>> Engineering BI
>>
>> On Mon, Jun 15, 2015 at 8:42 PM, Sneh <shanker.sneh@myntra.com> wrote:
>>
>>> Awesome Raju!
>>>
>>> It did the trick. Will follow up if I am stuck again. Thanks a lot!
>>>
>>> BR,
>>> *Sneh*
>>> Engineering BI
>>>
>>> On Mon, Jun 15, 2015 at 8:36 PM, Raju Bairishetti <raju.b41@gmail.com>
>>> wrote:
>>>
>>>> ).  It just adds all the hive jars based on HIVE_HOME env variable. But
>>>> the one you set HIVE_HOME does not contains any jars in the lib directory.
>>>>
>>>>  You should try HIVE_HOME with  /Users/shanker.sneh/hive-hive-
>>>> release-0.13.3-inm/packaging/target/apache-hive-0.13.4-inm-S
>>>> NAPSHOT-bin/apache-hive-0.13.4-inm-SNAPSHOT-bin/.
>>>>
>>>> Can you try and let us know the result?
>>>>
>>>> On Mon, Jun 15, 2015 at 8:13 PM, Sneh <shanker.sneh@myntra.com> wrote:
>>>>
>>>>> Hi Raju,
>>>>>
>>>>> My HIVE_HOME is proper.
>>>>>
>>>>> EN-ShankerS:bin shanker.sneh$ echo $HIVE_HOME
>>>>>
>>>>> /Users/shanker.sneh/hive-hive-release-0.13.3-inm
>>>>>
>>>>>
>>>>> The /server/bin/lens-ctl has the following piece of code:
>>>>>
>>>>>
>>>>> if [ "$HIVE_HOME" != "" ]; then
>>>>>
>>>>>     echo "HIVE_HOME is set, adding ${HIVE_HOME}/lib/* into lens
>>>>> classpath"
>>>>>
>>>>>     LENSCPPATH=${LENSCPPATH}:`ls ${HIVE_HOME}/lib/* 2>/dev/null |
tr
>>>>> "\n" ':' 2>/dev/null`
>>>>>
>>>>>   else
>>>>>
>>>>>     echo "HIVE_HOME is not set. Set HIVE_HOME and try again"
>>>>>
>>>>>     exit 1
>>>>>
>>>>>   fi
>>>>>
>>>>>
>>>>> Which is what I am getting the output.
>>>>>
>>>>> But /lib is empty for the forked hive, which seems wrong.
>>>>>
>>>>>
>>>>>
>>>>> BR,
>>>>> *Sneh*
>>>>> Engineering BI
>>>>>
>>>>> On Mon, Jun 15, 2015 at 8:02 PM, Raju Bairishetti <
>>>>> raju.bairishetti@inmobi.com> wrote:
>>>>>
>>>>>> Hi Sneh,
>>>>>>
>>>>>> *Hive home was set to:* /Users/shanker.sneh/hive-hive-
>>>>>> release-0.13.3-inm/lib/*
>>>>>>
>>>>>> I guess you are not setting HIVE_HOME properly.
>>>>>>
>>>>>> *Can you set HIVE_HOME like this and try?*
>>>>>>
>>>>>>  cd /Users/shanker.sneh/hive-hive-release-0.13.3-inm/
>>>>>>
>>>>>>  *cd
>>>>>> packaging/target/apache-hive-$project.version-bin/apache-hive-$project.version-bin*
>>>>>>
>>>>>>   export HIVE_HOME=`pwd`
>>>>>>
>>>>>>
>>>>>> On Mon, Jun 15, 2015 at 7:46 PM, Sneh <shanker.sneh@myntra.com>
>>>>>> wrote:
>>>>>>
>>>>>>> Hello,
>>>>>>>
>>>>>>> As Amreshwari pointed out, I built the forked hive.
>>>>>>>
>>>>>>> Below is the status:
>>>>>>>
>>>>>>> [INFO] Hive ............................................... SUCCESS
>>>>>>> [  1.685 s]
>>>>>>>
>>>>>>> [INFO] Hive Ant Utilities ................................. SUCCESS
>>>>>>> [  1.597 s]
>>>>>>>
>>>>>>> [INFO] Hive Shims Common .................................. SUCCESS
>>>>>>> [  0.926 s]
>>>>>>>
>>>>>>> [INFO] Hive Shims 0.20 .................................... SUCCESS
>>>>>>> [  0.654 s]
>>>>>>>
>>>>>>> [INFO] Hive Shims Secure Common ........................... SUCCESS
>>>>>>> [  0.901 s]
>>>>>>>
>>>>>>> [INFO] Hive Shims 0.20S ................................... SUCCESS
>>>>>>> [  0.596 s]
>>>>>>>
>>>>>>> [INFO] Hive Shims 0.23 .................................... SUCCESS
>>>>>>> [  2.165 s]
>>>>>>>
>>>>>>> [INFO] Hive Shims ......................................... SUCCESS
>>>>>>> [  0.322 s]
>>>>>>>
>>>>>>> [INFO] Hive Common ........................................ SUCCESS
>>>>>>> [  2.545 s]
>>>>>>>
>>>>>>> [INFO] Hive Serde ......................................... SUCCESS
>>>>>>> [  3.376 s]
>>>>>>>
>>>>>>> [INFO] Hive Metastore ..................................... SUCCESS
>>>>>>> [ 46.362 s]
>>>>>>>
>>>>>>> [INFO] Hive Query Language ................................ SUCCESS
>>>>>>> [02:43 min]
>>>>>>>
>>>>>>> [INFO] Hive Service ....................................... SUCCESS
>>>>>>> [01:36 min]
>>>>>>>
>>>>>>> [INFO] Hive JDBC .......................................... SUCCESS
>>>>>>> [  1.558 s]
>>>>>>>
>>>>>>> [INFO] Hive Beeline ....................................... SUCCESS
>>>>>>> [  0.954 s]
>>>>>>>
>>>>>>> [INFO] Hive CLI ........................................... SUCCESS
>>>>>>> [ 22.251 s]
>>>>>>>
>>>>>>> [INFO] Hive Contrib ....................................... SUCCESS
>>>>>>> [  0.855 s]
>>>>>>>
>>>>>>> [INFO] Hive HBase Handler ................................. SUCCESS
>>>>>>> [03:46 min]
>>>>>>>
>>>>>>> [INFO] Hive HCatalog ...................................... SUCCESS
>>>>>>> [ 20.885 s]
>>>>>>>
>>>>>>> [INFO] Hive HCatalog Core ................................. SUCCESS
>>>>>>> [ 18.957 s]
>>>>>>>
>>>>>>> [INFO] Hive HCatalog Pig Adapter .......................... SUCCESS
>>>>>>> [ 15.911 s]
>>>>>>>
>>>>>>> [INFO] Hive HCatalog Server Extensions .................... SUCCESS
>>>>>>> [01:25 min]
>>>>>>>
>>>>>>> [INFO] Hive HCatalog Webhcat Java Client .................. SUCCESS
>>>>>>> [  0.902 s]
>>>>>>>
>>>>>>> [INFO] Hive HCatalog Webhcat .............................. SUCCESS
>>>>>>> [01:07 min]
>>>>>>>
>>>>>>> [INFO] Hive HCatalog Streaming ............................ SUCCESS
>>>>>>> [  0.911 s]
>>>>>>>
>>>>>>> [INFO] Hive HWI ........................................... SUCCESS
>>>>>>> [  0.647 s]
>>>>>>>
>>>>>>> [INFO] Hive ODBC .......................................... SUCCESS
>>>>>>> [  0.367 s]
>>>>>>>
>>>>>>> [INFO] Hive Shims Aggregator .............................. SUCCESS
>>>>>>> [  0.070 s]
>>>>>>>
>>>>>>> [INFO] Hive TestUtils ..................................... SUCCESS
>>>>>>> [  9.103 s]
>>>>>>>
>>>>>>> [INFO] Hive Packaging ..................................... SUCCESS
>>>>>>> [11:32 min]
>>>>>>>
>>>>>>> [INFO]
>>>>>>> ------------------------------------------------------------------------
>>>>>>>
>>>>>>> [INFO] BUILD SUCCESS
>>>>>>>
>>>>>>>
>>>>>>> But the /lib folder is empty!
>>>>>>>
>>>>>>>
>>>>>>> So I couldn't do a /bin/hive (gives error: Missing Hive Execution
>>>>>>> Jar: /Users/shanker.sneh/hive-hive-release-0.13.3-inm/lib/hive-exec-*.jar)
>>>>>>>
>>>>>>>
>>>>>>> Now I start the Lens server (with Hadoop running localhost:8088):
>>>>>>>
>>>>>>>
>>>>>>> EN-ShankerS:bin shanker.sneh$ sh lens-ctl start
>>>>>>>
>>>>>>> Adding hadoop libs in classpath from /Users/shanker.sneh/hadoop
>>>>>>>
>>>>>>> HIVE_HOME is set, adding
>>>>>>> /Users/shanker.sneh/hive-hive-release-0.13.3-inm/lib/* into lens
classpath
>>>>>>>
>>>>>>> Started lens server!
>>>>>>>
>>>>>>>
>>>>>>> But when I goto the web browser, I get "webpage doesn't exist".
>>>>>>>
>>>>>>> Tried both the URLs - localhost:9999/lensapi/ &
>>>>>>> localhost:19999/index.html
>>>>>>>
>>>>>>>
>>>>>>> My lens-site.xml looks like:
>>>>>>>
>>>>>>> <property>
>>>>>>>
>>>>>>>   <name>lens.server.base.url</name>
>>>>>>>
>>>>>>>   <value>http://localhost:9999/lensapi/</value>
>>>>>>>
>>>>>>> </property>
>>>>>>>
>>>>>>>
>>>>>>> <property>
>>>>>>>
>>>>>>>   <name>lens.server.ui.base.uri</name>
>>>>>>>
>>>>>>>   <value>http://localhost:19999/</value>
>>>>>>>
>>>>>>> </property>
>>>>>>>
>>>>>>>
>>>>>>> <property>
>>>>>>>
>>>>>>>   <name>lens.server.drivers</name>
>>>>>>>
>>>>>>>
>>>>>>> <value>org.apache.lens.driver.hive.HiveDriver,org.apache.lens.driver.jdbc.JDBCDriver</value>
>>>>>>>
>>>>>>> </property>
>>>>>>>
>>>>>>>
>>>>>>> <property>
>>>>>>>
>>>>>>>   <name>lens.server.database.resource.dir</name>
>>>>>>>
>>>>>>>   <value>/tmp/lens/resources</value>
>>>>>>>
>>>>>>> </property>
>>>>>>>
>>>>>>> BR,
>>>>>>> *Sneh*
>>>>>>> Engineering BI
>>>>>>>
>>>>>>> On Mon, Jun 15, 2015 at 4:45 PM, Raju Bairishetti <
>>>>>>> raju.bairishetti@inmobi.com> wrote:
>>>>>>>
>>>>>>>> @Deepak, UI server is different from web server. I think
you are
>>>>>>>> pointing only UI server.
>>>>>>>>
>>>>>>>> @Sneh can you please paste the error?
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> On Mon, Jun 15, 2015 at 4:35 PM, Deepak Kumar Barr (Tech_BLR)
<
>>>>>>>> deepak.barr@flipkart.com> wrote:
>>>>>>>>
>>>>>>>>> Hey sneh,
>>>>>>>>>
>>>>>>>>>     The URL is incorrect. The UI is available at
>>>>>>>>> http://localhost:19999/index.html
>>>>>>>>>
>>>>>>>>> Regards,
>>>>>>>>> Deepak Kumar Barr
>>>>>>>>>
>>>>>>>>> On Mon, Jun 15, 2015 at 4:26 PM, Sneh <shanker.sneh@myntra.com>
>>>>>>>>> wrote:
>>>>>>>>>
>>>>>>>>>> Thanks Amareshwari.
>>>>>>>>>>
>>>>>>>>>> I built the Inmobi forked hive. HIVE_HOME is good
too.
>>>>>>>>>> Could go into the Hive prompt successfully.
>>>>>>>>>>
>>>>>>>>>> But when I start the lens-ctl, I get:
>>>>>>>>>>
>>>>>>>>>> EN-ShankerS:bin shanker.sneh$ sh lens-ctl start
>>>>>>>>>>
>>>>>>>>>> Adding hadoop libs in classpath from /Users/shanker.sneh/hadoop
>>>>>>>>>>
>>>>>>>>>> HIVE_HOME is set, adding
>>>>>>>>>> /Users/shanker.sneh/hive-hive-release-0.13.3-inm/lib/*
into lens classpath
>>>>>>>>>>
>>>>>>>>>> Started lens server!
>>>>>>>>>>
>>>>>>>>>> EN-ShankerS:bin shanker.sneh$
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> But the "webpage is not available" at localhost:9999/lensapi/.
>>>>>>>>>>
>>>>>>>>>> Same error as before, which I was getting using 
Hive 1.0
>>>>>>>>>>
>>>>>>>>>> BR,
>>>>>>>>>> *Sneh*
>>>>>>>>>> Engineering BI
>>>>>>>>>>
>>>>>>>>>> On Mon, Jun 15, 2015 at 4:03 PM, amareshwarisr .
<
>>>>>>>>>> amareshwari@gmail.com> wrote:
>>>>>>>>>>
>>>>>>>>>>> Hello Sneh,
>>>>>>>>>>>
>>>>>>>>>>> Thanks for reaching out. Lens depends on a forked
version of
>>>>>>>>>>> Hive as of now.
>>>>>>>>>>>
>>>>>>>>>>> Please see
>>>>>>>>>>> http://lens.incubator.apache.org/lenshome/install-and-run.html#Installing_and_Running_Lens
>>>>>>>>>>> and
>>>>>>>>>>> http://lens.incubator.apache.org/developer/contribute.html#Building_Hive_from_Source
>>>>>>>>>>> for how to build from forked hive.
>>>>>>>>>>>
>>>>>>>>>>> Thanks
>>>>>>>>>>> Amareshwari
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> On Mon, Jun 15, 2015 at 3:55 PM, Sneh <shanker.sneh@myntra.com>
>>>>>>>>>>> wrote:
>>>>>>>>>>>
>>>>>>>>>>>> Hello all,
>>>>>>>>>>>>
>>>>>>>>>>>> I am trying my hands on Lens. So need your
help with this.
>>>>>>>>>>>>
>>>>>>>>>>>> I have HDFS & hive running on my local
(Mac OS) in stand alone
>>>>>>>>>>>> mode.
>>>>>>>>>>>>
>>>>>>>>>>>> I have my lens-site.xml as:
>>>>>>>>>>>> <property>
>>>>>>>>>>>>   <name>lens.server.base.url</name>
>>>>>>>>>>>>   <value>localhost:9999/lensapi/</value>
>>>>>>>>>>>> </property>
>>>>>>>>>>>>
>>>>>>>>>>>> <property>
>>>>>>>>>>>>   <name>lens.server.drivers</name>
>>>>>>>>>>>>
>>>>>>>>>>>> <value>org.apache.lens.driver.hive.HiveDriver,org.apache.lens.driver.jdbc.JDBCDriver</value>
>>>>>>>>>>>> </property>
>>>>>>>>>>>>
>>>>>>>>>>>> <property>
>>>>>>>>>>>>   <name>lens.server.database.resource.dir</name>
>>>>>>>>>>>>   <value>/tmp/lens/resources</value>
>>>>>>>>>>>> </property>
>>>>>>>>>>>>
>>>>>>>>>>>> When I do a lens-ctl start, I get the message
"Started lens
>>>>>>>>>>>> server!".
>>>>>>>>>>>> But the browser doesn't open the URL localhost:9999/lensapi/
>>>>>>>>>>>>
>>>>>>>>>>>> I am sure I am missing something very important,
but unable to
>>>>>>>>>>>> figure out what.
>>>>>>>>>>>> So didn't try starting the client as the
server URL isn't
>>>>>>>>>>>> working for me.
>>>>>>>>>>>>
>>>>>>>>>>>> Server log says:
>>>>>>>>>>>> Exception in thread "main" java.lang.NoSuchFieldError:
>>>>>>>>>>>> HIVE_SESSION_IMPL_CLASSNAME
>>>>>>>>>>>> at
>>>>>>>>>>>> org.apache.lens.server.LensServices.init(LensServices.java:146)
>>>>>>>>>>>> at
>>>>>>>>>>>> org.apache.lens.server.LensServer.startServices(LensServer.java:133)
>>>>>>>>>>>> at org.apache.lens.server.LensServer.<init>(LensServer.java:87)
>>>>>>>>>>>> at
>>>>>>>>>>>> org.apache.lens.server.LensServer.createLensServer(LensServer.java:76)
>>>>>>>>>>>> at org.apache.lens.server.LensServer.main(LensServer.java:186)
>>>>>>>>>>>>
>>>>>>>>>>>> It might have something to do with hive.
>>>>>>>>>>>> My hive-site.xml says:
>>>>>>>>>>>> <property>
>>>>>>>>>>>>   <name>fs.default.name</name>
>>>>>>>>>>>>   <value>hdfs://localhost:8088</value>
>>>>>>>>>>>> </property>
>>>>>>>>>>>>
>>>>>>>>>>>> <property>
>>>>>>>>>>>>   <name>mapred.job.tracker</name>
>>>>>>>>>>>>   <value>localhost:8021</value>
>>>>>>>>>>>> </property>
>>>>>>>>>>>>
>>>>>>>>>>>> <property>
>>>>>>>>>>>>     <name>hive.metastore.local</name>
>>>>>>>>>>>>     <value>TRUE</value>
>>>>>>>>>>>>    </property>
>>>>>>>>>>>>
>>>>>>>>>>>> <property>
>>>>>>>>>>>> <name>javax.jdo.option.ConnectionURL</name>
>>>>>>>>>>>>
>>>>>>>>>>>> <value>jdbc:derby:;databaseName=/Users/shanker.sneh/hive/metastore_db;create=true</value>
>>>>>>>>>>>> </property>
>>>>>>>>>>>>
>>>>>>>>>>>> Sorry for the trivial question apparently.
>>>>>>>>>>>> Also please point out any prerequisite step
which I am missing.
>>>>>>>>>>>>
>>>>>>>>>>>> BR,
>>>>>>>>>>>> *Sneh*
>>>>>>>>>>>> Engineering BI
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> ------------------------------------------------------------------------------------------------------------------------------------------
>>>>>>>>>
>>>>>>>>> This email and any files transmitted with it are confidential
and
>>>>>>>>> intended solely for the use of the individual or entity
to whom they are
>>>>>>>>> addressed. If you have received this email in error please
notify the
>>>>>>>>> system manager. This message contains confidential information
and is
>>>>>>>>> intended only for the individual named. If you are not
the named addressee
>>>>>>>>> you should not disseminate, distribute or copy this e-mail.
Please notify
>>>>>>>>> the sender immediately by e-mail if you have received
this e-mail by
>>>>>>>>> mistake and delete this e-mail from your system. If you
are not the
>>>>>>>>> intended recipient you are notified that disclosing,
copying, distributing
>>>>>>>>> or taking any action in reliance on the contents of this
information is
>>>>>>>>> strictly prohibited. Although Flipkart has taken reasonable
precautions to
>>>>>>>>> ensure no viruses are present in this email, the company
cannot accept
>>>>>>>>> responsibility for any loss or damage arising from the
use of this email or
>>>>>>>>> attachments
>>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> --
>>>>>>>> Thanks & Regards,
>>>>>>>> Raju Bairishetti,
>>>>>>>> 8197553455,
>>>>>>>>
>>>>>>>>
>>>>>>>> _____________________________________________________________
>>>>>>>> The information contained in this communication is intended
solely
>>>>>>>> for the use of the individual or entity to whom it is addressed
and others
>>>>>>>> authorized to receive it. It may contain confidential or
legally privileged
>>>>>>>> information. If you are not the intended recipient you are
hereby notified
>>>>>>>> that any disclosure, copying, distribution or taking any
action in reliance
>>>>>>>> on the contents of this information is strictly prohibited
and may be
>>>>>>>> unlawful. If you have received this communication in error,
please notify
>>>>>>>> us immediately by responding to this email and then delete
it from your
>>>>>>>> system. The firm is neither liable for the proper and complete
transmission
>>>>>>>> of the information contained in this communication nor for
any delay in its
>>>>>>>> receipt.
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>
>>>>>>
>>>>>> --
>>>>>> Thanks & Regards,
>>>>>> Raju Bairishetti,
>>>>>> 8197553455,
>>>>>>
>>>>>>
>>>>>> _____________________________________________________________
>>>>>> The information contained in this communication is intended solely
>>>>>> for the use of the individual or entity to whom it is addressed and
others
>>>>>> authorized to receive it. It may contain confidential or legally
privileged
>>>>>> information. If you are not the intended recipient you are hereby
notified
>>>>>> that any disclosure, copying, distribution or taking any action in
reliance
>>>>>> on the contents of this information is strictly prohibited and may
be
>>>>>> unlawful. If you have received this communication in error, please
notify
>>>>>> us immediately by responding to this email and then delete it from
your
>>>>>> system. The firm is neither liable for the proper and complete transmission
>>>>>> of the information contained in this communication nor for any delay
in its
>>>>>> receipt.
>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>> --
>>>> Thanks
>>>> Raju Bairishetti,
>>>>
>>>> www.inmobi.com
>>>>
>>>>
>>>>
>>>>
>>>> *2012 ME Best Mobile Ad Network Award Winner
>>>>
>>>> [image: http://www.inmobi.com/press-releases/files/2013/02/MIT.png]
>>>>
>>>>
>>>>
>>>
>>
>

Mime
View raw message