lens-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rajat Khandelwal <rajatgupt...@gmail.com>
Subject Re: Question about Installation
Date Thu, 12 Nov 2015 18:41:33 GMT
Hi Raj

I don't see any issues, but jus to re iterate, here's what I did after
which I verified the server to be up.


rajat.khandelwal@lappy:~/apache-lens-2.3.0-beta-bin [0]
$ ls
LICENSE LICENSE-CDDLv1.1-GPLv2_withCPE LICENSE-GPLv3 README
LICENSE-CDDL-v1.0 LICENSE-EDL LICENSE-LGPL client
LICENSE-CDDLv1.0-GPLv2_withCPE LICENSE-EPL NOTICE server
rajat.khandelwal@lappy:~/apache-lens-2.3.0-beta-bin [0]
$ cd server/
rajat.khandelwal@lappy:~/apache-lens-2.3.0-beta-bin/server [0]
$ ls
bin conf conf-pseudo-distr webapp
rajat.khandelwal@lappy:~/apache-lens-2.3.0-beta-bin/server [0]
$ bin/lens-ctl start
/Users/rajat.khandelwal/apache-lens-2.3.0-beta-bin/server
Adding hadoop libs in classpath from /opt/hdp
HIVE_HOME is set, adding
/Users/rajat.khandelwal/Git/hive/packaging/target/apache-hive-0.13.4-inm-SNAPSHOT-bin/apache-hive-0.13.4-inm-SNAPSHOT-bin/lib/*
into lens classpath
Started lens server!
rajat.khandelwal@lappy:~/apache-lens-2.3.0-beta-bin/server [0]
$


Looking at your email, I wonder the error line in lens-config.sh has
something to do with the problem.

The class file is supposed to be here:

rajat.khandelwal@lappy:~/apache-lens-2.3.0-beta-bin/server [1]
$ ls
webapp/lens-server/WEB-INF/classes/org/apache/lens/server/LensServer.class
webapp/lens-server/WEB-INF/classes/org/apache/lens/server/LensServer.class

See if it's present.

On extraction of the tar, inside the webapp folder, lens-server.war file
should be present which should auto-extract and create lens-server folder
on server start.

Mime
View raw message