libcloud-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian Curtin (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LIBCLOUD-456) Promote methods for the SSH key pair management to be part of the base compute API
Date Fri, 06 Dec 2013 20:19:36 GMT

    [ https://issues.apache.org/jira/browse/LIBCLOUD-456?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13841656#comment-13841656
] 

Brian Curtin commented on LIBCLOUD-456:
---------------------------------------

Rather than "import_key_pair_from_string" and "import_key_pair_from_file" being public, could
we have "import_key_pair(self, name, key_stuff)" and then run checks from there? If key_stuff
is a valid file path, open and read from it. If it's key contents, work with it as-is.


* key_stuff is clearly a bad parameter name :)

> Promote methods for the SSH key pair management to be part of the base compute API
> ----------------------------------------------------------------------------------
>
>                 Key: LIBCLOUD-456
>                 URL: https://issues.apache.org/jira/browse/LIBCLOUD-456
>             Project: Libcloud
>          Issue Type: New Feature
>            Reporter: Tomaz Muraus
>            Assignee: Tomaz Muraus
>            Priority: Minor
>
> As discussed on the mailing list, promote key pair management methods to be part of the
base compute API.
> This issue also includes updating all the existing drivers which currently expose key
pair management through the extension methods to use a new standard API.
> Mailing list thread: http://mail-archives.apache.org/mod_mbox/libcloud-dev/201312.mbox/%3CCAJMHEmKOsFYJZDZQLb_Z2q1Rs8Ke%2B%2BxUNnqqEbPjyTccTgPYHQ%40mail.gmail.com%3E
> Proposed API: https://gist.github.com/Kami/7810989



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message