libcloud-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ryan McLean (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (LIBCLOUD-542) Authentication against OpenStack stopped working
Date Fri, 11 Dec 2015 15:09:11 GMT

    [ https://issues.apache.org/jira/browse/LIBCLOUD-542?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15052871#comment-15052871
] 

Ryan McLean edited comment on LIBCLOUD-542 at 12/11/15 3:09 PM:
----------------------------------------------------------------

I have the same issue:
The following fails:

from libcloud.compute.types import Provider
from libcloud.compute.providers import get_driver

import libcloud.security

auth_usr   = 'ryan@ccc.sss.com'
auth_pass  = '*********'
auth_url   = 'https://ccc.sss.com:5000/v2.0'
project_name = 'POC'
region_name = ''

libcloud.security.VERIFY_SSL_CERT = False

provider = get_driver(Provider.OPENSTACK)
conn = provider(auth_usr,
                auth_pass,
                ex_force_auth_url=auth_url,
                ex_force_auth_version='2.0_password',
                ex_tenant_name=project_name,
                ex_force_service_region=region_name)

images = conn.list_images()

for image in images:
    print(image)

Stripping the /v2.0 or adding the /tokens results in endpoint not being found.
The following works. 

curl -X POST -i -k \
-H "Content-Type: application/json" \
-d '
{
 "auth": { 
 "passwordCredentials": { 
 "password": "*******", 
 "username": "ryan@ccc.sss.com"
 }, 
 "tenantName": "POC"
 } 
}' https://ccc.sss.com:5000/v2.0/tokens



was (Author: ryanm101):
I have the same issue:
The following fails:

from libcloud.compute.types import Provider
from libcloud.compute.providers import get_driver

import libcloud.security

auth_usr   = 'ryan@ccc.sss.com'
auth_pass  = '*********'
auth_url   = 'https://ccc.sss.com:5000/v2.0'
project_name = 'POC'
region_name = ''

libcloud.security.VERIFY_SSL_CERT = False

provider = get_driver(Provider.OPENSTACK)
conn = provider(auth_usr,
                auth_pass,
                ex_force_auth_url=auth_url,
                ex_force_auth_version='2.0_password',
                ex_tenant_name=project_name,
                ex_force_service_region=region_name)

images = conn.list_images()

for image in images:
    print(image)

Stripping the /v2.0 or adding the /tokens results in endpoint not being found.
The following works. 

curl -X POST -i -k \
-H "Content-Type: application/json" \
-d '
{
 "auth": { 
 "passwordCredentials": { 
 "password": "*******", 
 "username": "ryan@ccc.sss.com"
 }, 
 "tenantName": "POC"
 } 
}' https://ccc.sss.com:5000/v2.0/tokens


> Authentication against OpenStack stopped working
> ------------------------------------------------
>
>                 Key: LIBCLOUD-542
>                 URL: https://issues.apache.org/jira/browse/LIBCLOUD-542
>             Project: Libcloud
>          Issue Type: Bug
>          Components: Compute
>            Reporter: Torsten Schlabach
>            Priority: Blocker
>
> We are using the OpenStack driver against our own cloud server.
> This is the code we use for connecting and retrieving a list of images:
> fg_compute = driver(USERNAME, PASSWORD, host=STACKHOST, port=8774,
> secure=False,
>                     ex_tenant_name=TENANTNAME,
>                     ex_force_auth_version='2.0_password',
>                     ex_force_service_name='nova',
>                     ex_force_auth_url='http://%s:5000/v2.0/' % STACKHOST)
> images = fg_compute.list_images()
> This used to work until we switched to the latest trunk code today; now getting the following
error message:
> Traceback (most recent call last):
>   File "mail.py", line 86, in <module>
>     images = fg_compute.list_images()
>   File "/usr/local/lib/python2.7/dist-packages/apache_libcloud-0.14.1-py2.7.egg/libcloud/compute/drivers/openstack.py",
line 297, in list_images
>     self.connection.request('/images/detail').object, ex_only_active)
>   File "/usr/local/lib/python2.7/dist-packages/apache_libcloud-0.14.1-py2.7.egg/libcloud/compute/drivers/openstack.py",
line 161, in request
>     method=method, headers=headers)
>   File "/usr/local/lib/python2.7/dist-packages/apache_libcloud-0.14.1-py2.7.egg/libcloud/common/openstack.py",
line 575, in request
>     return super(OpenStackBaseConnection, self).request(**kwargs)
>   File "/usr/local/lib/python2.7/dist-packages/apache_libcloud-0.14.1-py2.7.egg/libcloud/common/base.py",
line 600, in request
>     action = self.morph_action_hook(action)
>   File "/usr/local/lib/python2.7/dist-packages/apache_libcloud-0.14.1-py2.7.egg/libcloud/common/openstack.py",
line 571, in morph_action_hook
>     self._populate_hosts_and_request_paths()
>   File "/usr/local/lib/python2.7/dist-packages/apache_libcloud-0.14.1-py2.7.egg/libcloud/common/openstack.py",
line 600, in _populate_hosts_and_request_paths
>     osa.authenticate()  # may throw InvalidCreds
>   File "/usr/local/lib/python2.7/dist-packages/apache_libcloud-0.14.1-py2.7.egg/libcloud/common/openstack.py",
line 157, in authenticate
>     return self.authenticate_2_0_with_password()
>   File "/usr/local/lib/python2.7/dist-packages/apache_libcloud-0.14.1-py2.7.egg/libcloud/common/openstack.py",
line 252, in authenticate_2_0_with_password
>     return self.authenticate_2_0_with_body(reqbody)
>   File "/usr/local/lib/python2.7/dist-packages/apache_libcloud-0.14.1-py2.7.egg/libcloud/common/openstack.py",
line 264, in authenticate_2_0_with_body
>     driver=self.driver)
> libcloud.common.types.MalformedResponseError: <MalformedResponseException in None
'Malformed response'>: 'code: 400 body: {"error": {"message": "get_version_v2() got an
unexpected keyword argument \'auth\'", "code": 400, "title": "Bad Request"}}'



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message