libcloud-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Miguel Caballer (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (LIBCLOUD-831) backports.ssl_match_hostname dependency not met in Ubuntu 14.04
Date Thu, 07 Jul 2016 09:57:10 GMT

     [ https://issues.apache.org/jira/browse/LIBCLOUD-831?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Miguel Caballer updated LIBCLOUD-831:
-------------------------------------
    Description: 
Installing libcloud with pip (with versions 1.0.0 and 1.1.0) in Ubuntu 14.04 (python versoin
2.7.6) the library "backports.ssl_match_hostname" is not installed and it fails with the error:

ImportError: No module named backports.ssl_match_hostname

In previous versions this error does not appear.

In Ubuntu 16.04 (python versoin 2.7.11) this error does not appear.

If I git clone the libcloud github repository and install with pip the directory:
  $ pip install . 
It works ...

Only the installation with pip command does not install the correct requirements:
  $ pip install apache-libcloud

  was:
Installing libcloud with pip (with versions 1.0.0 and 1.1.0) in Ubuntu 14.04 (python versoin
2.7.6) the library "backports.ssl_match_hostname" is not installed and it fails with the error:

ImportError: No module named backports.ssl_match_hostname

In previous versions this error does not appear.

In Ubuntu 16.04 (python versoin 2.7.11) this error does not appear.


> backports.ssl_match_hostname dependency not met in Ubuntu 14.04
> ---------------------------------------------------------------
>
>                 Key: LIBCLOUD-831
>                 URL: https://issues.apache.org/jira/browse/LIBCLOUD-831
>             Project: Libcloud
>          Issue Type: Bug
>          Components: Core
>            Reporter: Miguel Caballer
>              Labels: dependencies
>
> Installing libcloud with pip (with versions 1.0.0 and 1.1.0) in Ubuntu 14.04 (python
versoin 2.7.6) the library "backports.ssl_match_hostname" is not installed and it fails with
the error:
> ImportError: No module named backports.ssl_match_hostname
> In previous versions this error does not appear.
> In Ubuntu 16.04 (python versoin 2.7.11) this error does not appear.
> If I git clone the libcloud github repository and install with pip the directory:
>   $ pip install . 
> It works ...
> Only the installation with pip command does not install the correct requirements:
>   $ pip install apache-libcloud



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message