libcloud-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From anthonys...@apache.org
Subject [33/40] libcloud git commit: Merge update for version compare and fix pylint issues
Date Fri, 02 Dec 2016 04:33:35 GMT
Merge update for version compare and fix pylint issues


Project: http://git-wip-us.apache.org/repos/asf/libcloud/repo
Commit: http://git-wip-us.apache.org/repos/asf/libcloud/commit/ba6346f7
Tree: http://git-wip-us.apache.org/repos/asf/libcloud/tree/ba6346f7
Diff: http://git-wip-us.apache.org/repos/asf/libcloud/diff/ba6346f7

Branch: refs/heads/trunk
Commit: ba6346f7871ffc9451d5c3f45dafc516383d94f8
Parents: 4284c31
Author: Samuel Chong <samuelchong1@gmail.com>
Authored: Fri Nov 25 11:12:16 2016 +1100
Committer: Samuel Chong <samuelchong1@gmail.com>
Committed: Fri Nov 25 11:12:16 2016 +1100

----------------------------------------------------------------------
 libcloud/compute/drivers/dimensiondata.py | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/libcloud/blob/ba6346f7/libcloud/compute/drivers/dimensiondata.py
----------------------------------------------------------------------
diff --git a/libcloud/compute/drivers/dimensiondata.py b/libcloud/compute/drivers/dimensiondata.py
index 1455588..b0f248a 100644
--- a/libcloud/compute/drivers/dimensiondata.py
+++ b/libcloud/compute/drivers/dimensiondata.py
@@ -21,7 +21,7 @@ try:
 except ImportError:
     from xml.etree import ElementTree as ET
 
-from distutils.version import LooseVersion, StrictVersion
+from libcloud.common.dimensiondata import LooseVersion
 from libcloud.common.exceptions import BaseHTTPError
 from libcloud.compute.base import NodeDriver, Node, NodeAuthPassword
 from libcloud.compute.base import NodeSize, NodeImage, NodeLocation
@@ -904,7 +904,7 @@ class DimensionDataNodeDriver(NodeDriver):
         # Unsupported for version lower than 2.4
         if LooseVersion(self.connection.active_api_version) < LooseVersion(
                 '2.4'):
-            raise Exception("import image is feature is NOT supported in  " \
+            raise Exception("import image is feature is NOT supported in  "
                             "api version earlier than 2.4")
         elif cluster_id is None and datacenter_id is None:
             raise ValueError("Either cluster_id or datacenter_id must be "
@@ -2545,8 +2545,8 @@ class DimensionDataNodeDriver(NodeDriver):
         # Version 2.4 and higher
         else:
             clone_server_elem = ET.Element('cloneServer',
-                                             {'id': node_id,
-                                              'xmlns': TYPES_URN})
+                                           {'id': node_id,
+                                            'xmlns': TYPES_URN})
 
             ET.SubElement(clone_server_elem, 'imageName').text = image_name
 
@@ -3730,7 +3730,6 @@ class DimensionDataNodeDriver(NodeDriver):
         response_code = findtext(response, 'responseCode', TYPES_URN)
         return response_code in ['IN_PROGRESS', 'OK']
 
-
     def ex_exchange_nic_vlans(self, nic_id_1, nic_id_2):
         """
         Exchange NIC Vlans


Mime
View raw message