libcloud-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Markos Gogoulos (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LIBCLOUD-902) Invalid credentials with the provider error
Date Thu, 09 Mar 2017 14:52:38 GMT

    [ https://issues.apache.org/jira/browse/LIBCLOUD-902?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15903146#comment-15903146
] 

Markos Gogoulos commented on LIBCLOUD-902:
------------------------------------------

Clearly shows that the creds are incorrect. These are the creds you use for horizon dashboard,
make sure they are the same!

You might also need to specify a tenant_name, check examples on http://libcloud.readthedocs.io/en/latest/compute/drivers/openstack.html

> Invalid credentials with the provider  error
> --------------------------------------------
>
>                 Key: LIBCLOUD-902
>                 URL: https://issues.apache.org/jira/browse/LIBCLOUD-902
>             Project: Libcloud
>          Issue Type: Bug
>          Components: Compute
>            Reporter: sathyamoorthy
>            Priority: Blocker
>
> I have some issues with libcloud library when trying to retrieve the openstack instance
details. Please let me know if you have any idea on the below error. This error is not seen
in kilo setup. 
> --
> >>> driver.list_nodes()
> Traceback (most recent call last):
> File "/home/s.viswanathan/GV/lib/cloudlib.py", line 94, in show_instances
> ERROR 2017-03-07 04:04:20     nodes = sess.list_nodes()
> ERROR 2017-03-07 04:04:20   File "/usr/local/lib/python2.7/dist-packages/libcloud/compute/drivers/openstack.py",
line 177, in list_nodes
> ERROR 2017-03-07 04:04:20     self.connection.request('/servers/detail', params=params).object)
> ERROR 2017-03-07 04:04:20   File "/usr/local/lib/python2.7/dist-packages/libcloud/common/openstack.py",
line 227, in request
> ERROR 2017-03-07 04:04:20     raw=raw)
> ERROR 2017-03-07 04:04:20   File "/usr/local/lib/python2.7/dist-packages/libcloud/common/base.py",
line 757, in request
> ERROR 2017-03-07 04:04:20     action = self.morph_action_hook(action)
> ERROR 2017-03-07 04:04:20   File "/usr/local/lib/python2.7/dist-packages/libcloud/common/openstack.py",
line 294, in morph_action_hook
> ERROR 2017-03-07 04:04:20     self._populate_hosts_and_request_paths()
> ERROR 2017-03-07 04:04:20   File "/usr/local/lib/python2.7/dist-packages/libcloud/common/openstack.py",
line 327, in _populate_hosts_and_request_paths
> ERROR 2017-03-07 04:04:20     osa = osa.authenticate(**kwargs)  # may throw InvalidCreds
> ERROR 2017-03-07 04:04:20   File "/usr/local/lib/python2.7/dist-packages/libcloud/common/openstack_identity.py",
line 855, in authenticate
> ERROR 2017-03-07 04:04:20     return self._authenticate_2_0_with_password()
> ERROR 2017-03-07 04:04:20   File "/usr/local/lib/python2.7/dist-packages/libcloud/common/openstack_identity.py",
line 880, in _authenticate_2_0_with_password
> ERROR 2017-03-07 04:04:20     return self._authenticate_2_0_with_body(reqbody)
> ERROR 2017-03-07 04:04:20   File "/usr/local/lib/python2.7/dist-packages/libcloud/common/openstack_identity.py",
line 888, in _authenticate_2_0_with_body
> ERROR 2017-03-07 04:04:20     raise InvalidCredsError()
> ERROR 2017-03-07 04:04:20 InvalidCredsError: 'Invalid credentials with the provider'

> --
> I have tried from python interpreter manually also, seen same problem.
> from libcloud.compute.types import Provider
> from libcloud.compute.providers import get_driver
> import libcloud.security
> OpenStack = get_driver(Provider.OPENSTACK)
> driver = OpenStack('xxx', yyy',ex_force_auth_url='http://x.x.x.x:5000',ex_force_auth_version='2.0_password')
> driver.list_nodes()
> Thanks in advance,
> Sathya



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message