libcloud-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GitBox <...@apache.org>
Subject [GitHub] [libcloud] arterrey opened a new issue #1392: The wheel distribution of this package on pypi contains the requirement for enum34
Date Thu, 19 Dec 2019 08:26:22 GMT
arterrey opened a new issue #1392: The wheel distribution of this package on pypi contains
the requirement for enum34
URL: https://github.com/apache/libcloud/issues/1392
 
 
   ## Summary
   
   The wheel distribution of this package on pypi contains the requirement for enum34
   
   ## Detailed Information
   
   enum34 appears to be dynamical included as a requirement in setup.py depending if your
Python version is pre 3.4.
   
   ```
   PY2_or_3_pre_34 = sys.version_info < (3, 4, 0)
   # ...
   if PY2_or_3_pre_34:
       INSTALL_REQUIREMENTS.append('typing')
       INSTALL_REQUIREMENTS.append('enum34')
   ```
   
   The wheel package contains the requirement without any special qualifier. (I'm not even
sure if it is possible to spec requirements in a wheel according to python version)
   
   From METADATA
   ```
   Requires-Python: >=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, <4
   Requires-Dist: requests (>=2.5.0)
   Requires-Dist: typing
   Requires-Dist: enum34
   ```
   
   This does create a problem in `zc.buildout` style environments that are running newer python
versions.
   
   I think it is probably time to drop support for Python 3.3

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


With regards,
Apache Git Services

Mime
View raw message