libcloud-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tomaz Muraus <to...@apache.org>
Subject Re: connecting to rackspace
Date Tue, 04 Jun 2013 20:09:24 GMT
Run it with LIBCLOUD_DEBUG (http://libcloud.apache.org/docs/debugging.html) and
post the whole output here so we can see to which host it's actually trying
to connect.

On Tue, Jun 4, 2013 at 12:57 PM, martin vu <martin.vu@gmail.com> wrote:

> hi
>
> does anyone have any idea why I get this when connecting to rackspace
> cloud, this has worked previously
>
> I am using
>
> Driver = get_driver(getattr(Provider, LOCATION))
>     conn = Driver(RACKSPACE_USER, RACKSPACE_KEY)
>
> conn.list_images()
>
> and I get this following error
>
> /usr/lib64/python2.7/httplib.pyc in connect(self)
>    1155
>    1156             sock = socket.create_connection((self.host, self.port),
> -> 1157                                             self.timeout,
> self.source_address)
>    1158             if self._tunnel_host:
>    1159                 self.sock = sock
>
> /usr/lib64/python2.7/socket.pyc in create_connection(address, timeout,
> source_address)
>     551     host, port = address
>     552     err = None
> --> 553     for res in getaddrinfo(host, port, 0, SOCK_STREAM):
>     554         af, socktype, proto, canonname, sa = res
>     555         sock = None
>
> gaierror: [Errno -2] Name or service not known
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message