logging-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LOG4J2-1431) Simplify log4j system property naming scheme
Date Sat, 14 Oct 2017 17:21:03 GMT

    [ https://issues.apache.org/jira/browse/LOG4J2-1431?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16204741#comment-16204741

ASF subversion and git services commented on LOG4J2-1431:

Commit 36f70030762b9b29d87b747f769ef6f90f76c83b in logging-log4j2's branch refs/heads/master
from [~jvz]
[ https://git-wip-us.apache.org/repos/asf?p=logging-log4j2.git;h=36f7003 ]

Update manual for LOG4J2-1431 and LOG4J2-1809

> Simplify log4j system property naming scheme
> --------------------------------------------
>                 Key: LOG4J2-1431
>                 URL: https://issues.apache.org/jira/browse/LOG4J2-1431
>             Project: Log4j 2
>          Issue Type: Improvement
>            Reporter: Matt Sicker
>            Assignee: Matt Sicker
>             Fix For: 2.10.0
> As I wonder how to prefix yet another configurable system property, I noticed we have
five families of configuration name prefixes:
> log4j.*
> log4j2.*
> Log4j*
> org.apache.logging.log4j.*
> <no prefix>
> What I'd like to do is strip out all those prefixes and allow any of them, but change
the documentation to use only a single consistent prefix. This would also make it simpler
when writing the properties into a log4j2.component.properties file as you could omit all
the prefixes as they won't clash with other libraries.

This message was sent by Atlassian JIRA

View raw message