logging-log4j-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Smith <psm...@aconex.com>
Subject Re: Up-to-date build instructions for Apache chainsaw?
Date Mon, 30 Jun 2008 22:24:25 GMT
> P.S.: The chainsaw shell script is not executable by default on  
> Linux. I have no knowledge of maven scripts so far, but it might be  
> just a small change to include this?
>

The appassembler plugin for Maven does not provide that feature, which  
I believe is due to the fact that Java itself cannot set that flag,  
because not all O/S support the concept of executable.  Only a very  
recent version of Java actually exposes an API to tell if something is  
"executable" or not, yet still there's no way to set it I believe.

Details (the lacking of options) are here:

Appassembler

Paul


Mime
View raw message