logging-log4j-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 44386] NTEventLogAppender.dll for windows 64
Date Fri, 10 Jul 2009 21:43:29 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=44386


taohuang.tamu@gmail.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |taohuang.tamu@gmail.com




--- Comment #12 from taohuang.tamu@gmail.com  2009-07-10 14:43:24 PST ---
I am moving our web serviceon Tomcat to 64 bit. So I found this bug and used
the patch in attachment. I followed the instructions in your patch_readme,
although the webservice and Tomcat 64bit both work fine, I don't see any logs
output. Tomcat logs don't give any errors or complaints though. So would you
please have a look of what I'm doing wrong? This is what I did:

1) build.xml I put AppenderNT.jar before log4j-1.2.14.jar
     ...
     <pathelement location="${AppenderNT-jar}"/>
     <pathelement location="${log4j-jar}"/>

2) put the NTEventLogAppender64.dll under tomcat\bin

3) put AppenderNT.jar under tomcat\lib

4) check tomcat\webapps\mine\WEB-INF\lib, verify that file
AppenderNT.jar is there

BTW, it's been almost a year since the last update on this bug. Any update?
Will there be any official support of 64bit NTEventLogAppender from log4j?

Thanks!

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: log4j-dev-unsubscribe@logging.apache.org
For additional commands, e-mail: log4j-dev-help@logging.apache.org


Mime
View raw message