logging-log4j-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 47595] [companion] POMs of companions have problems
Date Sun, 04 Oct 2009 04:13:14 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=47595

Curt Arnold <carnold@apache.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|RESOLVED                    |REOPENED
         Resolution|FIXED                       |

--- Comment #5 from Curt Arnold <carnold@apache.org> 2009-10-03 21:13:11 PDT ---
Sorry, I thought I had commented on this on the mailing list.

javax.xml.parsers was available for earlier JDK's as an additional component.

The source and target parameters on a Java compiler do not indicate the version
of JDK necessary to build the component, they specify the version of the Java
language specification accepted and the version of the Java byte-code emitted. 
There are specific reasons why 1.1 was chose for byte-code and 1.2 was selected
for source.  Those choices were made a long time ago and maybe the should be
review but the post did indicate any specific problem that occurred due to that
choice or advantage that would be gained by changing the versions.  As deep in
the maintenance cycle as log4j 1.2 is, it seems unwise to make changes for no
defined benefit.

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: log4j-dev-unsubscribe@logging.apache.org
For additional commands, e-mail: log4j-dev-help@logging.apache.org


Mime
View raw message