logging-log4j-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Gregory <garydgreg...@gmail.com>
Subject Rename Marker.add(Marker)
Date Thu, 01 May 2014 13:57:29 GMT
I find the API name Marker.add(Marker) unclear.

OTOH, Marker.setParents(Marker...) is clear.

I propose to rename add(Marker) to addParent(Marker).

And I do not want to think about addChild(Marker) ;)


E-Mail: garydgregory@gmail.com | ggregory@apache.org
Java Persistence with Hibernate, Second Edition<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory

View raw message