logging-log4j-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Sicker <boa...@gmail.com>
Subject Re: Rename Marker.add(Marker)
Date Sat, 03 May 2014 02:10:39 GMT
Holy crap, this is the biggest mix of programming languages I've seen since
Git! Perl, C, Python, Bash, Ruby, Makefiles, setup.py, the works. I'll see
what I can figure out.


On 2 May 2014 17:17, Matt Sicker <boards@gmail.com> wrote:

> I'll take a look at the project.
>
>
> On 2 May 2014 16:13, Ralph Goers <ralph.goers@dslextreme.com> wrote:
>
>> If you have time can you see how to do a vote with Apache Steve?  That is
>> the tool the ASF uses to vote on the board of directors and new members.
>>
>> Ralph
>>
>>
>> On May 2, 2014, at 1:30 PM, Matt Sicker <boards@gmail.com> wrote:
>>
>> AddParents it is then! Speaking of arguments, how do we vote on the new
>> logo?
>>
>>
>> On 2 May 2014 15:04, Ralph Goers <ralph.goers@dslextreme.com> wrote:
>>
>>> What is an “Extends”?  I’m implementing addParents.  I’m getting tired
>>> of “arguments” about names. I’m still having trouble figuring out what
a
>>> LoggerProvider is if it isn’t a Factory and is, in fact, a Logger.
>>>
>>> Ralph
>>>
>>> On May 2, 2014, at 12:51 PM, Bruce Brouwer <bruce.brouwer@gmail.com>
>>> wrote:
>>>
>>> I realized that after I sent that that we cannot call the method
>>> extends(...) as it is a reserved word. We could call it setExtends(...) and
>>> addExtends(...).
>>>
>>> My first vote is for set/addExtends(...). My second choice is
>>> set/addParents(...).
>>> On May 2, 2014 3:16 PM, "Matt Sicker" <boards@gmail.com> wrote:
>>>
>>>> Wait a minute. Extends sounds like a great method name!
>>>>
>>>>
>>>> On 2 May 2014 11:04, Ralph Goers <ralph.goers@dslextreme.com> wrote:
>>>>
>>>>> I started the work on that.  Should have it finished tonight.
>>>>>
>>>>> Ralph
>>>>>
>>>>> On May 2, 2014, at 6:51 AM, Gary Gregory <garydgregory@gmail.com>
>>>>> wrote:
>>>>>
>>>>> I think all that is needed is to rename add(M...) to addParents(M...)
>>>>>
>>>>> Gary
>>>>>
>>>>>
>>>>> On Thu, May 1, 2014 at 11:37 PM, Bruce Brouwer <
>>>>> bruce.brouwer@gmail.com> wrote:
>>>>>
>>>>>> I would be in favor of renaming .add(Marker parent) to
>>>>>> .addParents(Marker... parents). If people think it's a big deal,
we could
>>>>>> have .addParent(Marker parent) and .addParents(Marker... parents),
but I
>>>>>> don't see a lot of value in having two methods.
>>>>>>
>>>>>> It is true, I do really want to have the vararg version.
>>>>>>
>>>>>> We could go crazy and rename .setParents(Marker... parents) to
>>>>>> .extends(Marker... markers) and .add(Marker parent) to
>>>>>> .andExtends(Marker... markers). That would go along with the interface
>>>>>> nomenclature used of .isInstanceOf(Marker marker)
>>>>>>
>>>>>>
>>>>>> On Thu, May 1, 2014 at 4:16 PM, Matt Sicker <boards@gmail.com>
wrote:
>>>>>>
>>>>>>> So it seems like using the word "add" in this context sort of
>>>>>>> implies adding a child or contained marker when it actually does
the
>>>>>>> opposite. A word like "with" or "from" or "using" might make
more sense if
>>>>>>> we wanted to keep the single word method name idea. Otherwise,
addParent[s]
>>>>>>> or parent[s] might work, too.
>>>>>>>
>>>>>>> And in regards to the logo, what's the next step? Run-off voting
on
>>>>>>> the remaining candidates?
>>>>>>>
>>>>>>>
>>>>>>> On 1 May 2014 09:25, Gary Gregory <garydgregory@gmail.com>
wrote:
>>>>>>>
>>>>>>>> Well, a hierarchy has has node that are parents and children.
>>>>>>>>
>>>>>>>> Our docs say:
>>>>>>>>
>>>>>>>> /**
>>>>>>>>  *  Markers are objects that are used to add easily filterable
>>>>>>>> information to log messages.
>>>>>>>>  *
>>>>>>>>  *  Markers can be hierarchical - each Marker may have a
parent.
>>>>>>>> This allows for broad categories
>>>>>>>>  *  being subdivided into more specific categories. An example
>>>>>>>> might be a Marker named "Error" with
>>>>>>>>  *  children named "SystemError" and "ApplicationError".
>>>>>>>>  */
>>>>>>>>
>>>>>>>>
>>>>>>>> But if I can make this easy mistake:
>>>>>>>>
>>>>>>>> Marker err = MarkerManager.getMarker("Error");
>>>>>>>> arker serr = MarkerManager.getMarker("SysError");
>>>>>>>> Marker aerr = MarkerManager.getMarker("AppError");
>>>>>>>> err.add(serr);
>>>>>>>> err.add(aerr);
>>>>>>>>
>>>>>>>> Instead I have to do:
>>>>>>>>
>>>>>>>> serr.add(err);
>>>>>>>> aerr.add(err);
>>>>>>>>
>>>>>>>> If the API tells me the relationship, if I have to write
backwards
>>>>>>>> code, then I can see it is backward ;)
>>>>>>>>
>>>>>>>> // no addChild API
>>>>>>>> serr.addParent(err);
>>>>>>>> aerr.addParent(err);
>>>>>>>>
>>>>>>>> And of course forget the obvious:
>>>>>>>>
>>>>>>>> err.addChildren(serr, aerr)
>>>>>>>>
>>>>>>>> so addParents(Marker...) would be OK too.
>>>>>>>>
>>>>>>>> Gary
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> On Thu, May 1, 2014 at 10:07 AM, Ralph Goers <rgoers@apache.org>wrote:
>>>>>>>>
>>>>>>>>> Well, Bruce wants that method to accept a variable number
of
>>>>>>>>> Markers, so a name that is singular would be awkward.
 What else would one
>>>>>>>>> be adding?
>>>>>>>>>
>>>>>>>>> It seems like we spend more time discussing renames than
anything
>>>>>>>>> else - like actually picking a logo.
>>>>>>>>>
>>>>>>>>> Ralph
>>>>>>>>>
>>>>>>>>> On May 1, 2014, at 6:57 AM, Gary Gregory <garydgregory@gmail.com>
>>>>>>>>> wrote:
>>>>>>>>>
>>>>>>>>> I find the API name Marker.add(Marker) unclear.
>>>>>>>>>
>>>>>>>>> OTOH, Marker.setParents(Marker...) is clear.
>>>>>>>>>
>>>>>>>>> I propose to rename add(Marker) to addParent(Marker).
>>>>>>>>>
>>>>>>>>> And I do not want to think about addChild(Marker) ;)
>>>>>>>>>
>>>>>>>>> Gary
>>>>>>>>>
>>>>>>>>> --
>>>>>>>>> E-Mail: garydgregory@gmail.com | ggregory@apache.org
>>>>>>>>> Java Persistence with Hibernate, Second Edition<http://www.manning.com/bauer3/>
>>>>>>>>> JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
>>>>>>>>> Spring Batch in Action <http://www.manning.com/templier/>
>>>>>>>>> Blog: http://garygregory.wordpress.com
>>>>>>>>> Home: http://garygregory.com/
>>>>>>>>> Tweet! http://twitter.com/GaryGregory
>>>>>>>>>
>>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> --
>>>>>>>> E-Mail: garydgregory@gmail.com | ggregory@apache.org
>>>>>>>> Java Persistence with Hibernate, Second Edition<http://www.manning.com/bauer3/>
>>>>>>>> JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
>>>>>>>> Spring Batch in Action <http://www.manning.com/templier/>
>>>>>>>> Blog: http://garygregory.wordpress.com
>>>>>>>> Home: http://garygregory.com/
>>>>>>>> Tweet! http://twitter.com/GaryGregory
>>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> --
>>>>>>> Matt Sicker <boards@gmail.com>
>>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> --
>>>>>>
>>>>>> Bruce Brouwer
>>>>>>
>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> E-Mail: garydgregory@gmail.com | ggregory@apache.org
>>>>> Java Persistence with Hibernate, Second Edition<http://www.manning.com/bauer3/>
>>>>> JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
>>>>> Spring Batch in Action <http://www.manning.com/templier/>
>>>>> Blog: http://garygregory.wordpress.com
>>>>> Home: http://garygregory.com/
>>>>> Tweet! http://twitter.com/GaryGregory
>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>> --
>>>> Matt Sicker <boards@gmail.com>
>>>>
>>>
>>>
>>
>>
>> --
>> Matt Sicker <boards@gmail.com>
>>
>>
>>
>
>
> --
> Matt Sicker <boards@gmail.com>
>



-- 
Matt Sicker <boards@gmail.com>

Mime
View raw message