logging-log4j-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ralph Goers <ralph.go...@dslextreme.com>
Subject Re: Config element name confusion
Date Mon, 07 Jul 2014 17:44:52 GMT
Well, If there is only one Filter then it would just be declared. If there is more than one
then it should be:

<Filters>
  <Filter>…</Filter>
  <Filter>…</Filter>
<Filters>

Even in this case since there is only the CompositeFilter (which contains the other Filters)
there should only be one Filter and it should be declared as PluginElement(“Filter”).
 The only place PluginElement(“Fitlers”) should be used is on CompositeFilter.  FileAppender
would be wrong to have “Filters” specified.

Ralph


On Jul 7, 2014, at 9:57 AM, Gary Gregory <garydgregory@gmail.com> wrote:

> This one would not need to be fixed: org.apache.logging.log4j.core.appender.RollingFileAppender.createAppender:
> 
>     @PluginFactory
>     public static RollingFileAppender createAppender(
> ...
>             @PluginElement("Filter") final Filter filter,
> ...
> 
> So we do have some inconsistencies.
> 
> 
> Gary
> 
> 
> On Mon, Jul 7, 2014 at 12:37 PM, Gary Gregory <garydgregory@gmail.com> wrote:
> I see:
> 
> org.apache.logging.log4j.core.filter.CompositeFilter.createFilters(Filter[]):
> 
>     @PluginFactory
>     public static CompositeFilter createFilters(@PluginElement("Filters") final Filter[]
filters) {
> 
> Which is clear, but then I see:
> 
>     public static FileAppender createAppender(
>             // @formatter:off
> ...
>             @PluginElement("Filters") final Filter filter,
> ...
> 
> So it seems like one filter elements (not arrays) should be renamed from "Filters" to
"Filter".
> 
> That or the discrepancy between the plural name and singular element needs to be in the
Javadoc.
> 
> Thoughts?
> 
> 
> -- 
> E-Mail: garydgregory@gmail.com | ggregory@apache.org 
> Java Persistence with Hibernate, Second Edition
> JUnit in Action, Second Edition
> Spring Batch in Action
> Blog: http://garygregory.wordpress.com 
> Home: http://garygregory.com/
> Tweet! http://twitter.com/GaryGregory
> 
> 
> 
> -- 
> E-Mail: garydgregory@gmail.com | ggregory@apache.org 
> Java Persistence with Hibernate, Second Edition
> JUnit in Action, Second Edition
> Spring Batch in Action
> Blog: http://garygregory.wordpress.com 
> Home: http://garygregory.com/
> Tweet! http://twitter.com/GaryGregory


Mime
View raw message