logging-log4j-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ralph Goers (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (LOG4J2-1336) LoggerFactory in 1.2 API module is not compatible with 1.2
Date Fri, 01 Apr 2016 02:04:25 GMT

    [ https://issues.apache.org/jira/browse/LOG4J2-1336?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15220986#comment-15220986
] 

Ralph Goers edited comment on LOG4J2-1336 at 4/1/16 2:03 AM:
-------------------------------------------------------------

I don't understand how LoggerFactoryBridge could be replaced with LoggerAdapter. Each of the
interfaces contain a single method and both take a name, but makeNewLoggerInstance requires
the LoggerContext while LoggerAdapter does not. LoggerAdapter is very similar to LoggerFactory
but LoggerAdapter cannot be used - it must be exactly the same as the Log4j 1.x LoggerFactory
interface.

I suppose if Category extends AbstractLoggerAdapter it might work.


was (Author: ralph.goers@dslextreme.com):
I don't understand how LoggerFactoryBridge could be replaced with LoggerAdapter. Each of the
interfaces contain a single method and both take a name, but makeNewLoggerInstance requires
the LoggerContext while LoggerAdapter does not. LoggerAdapter is very similar to LoggerFactory
but LoggerAdapter cannot be used - it must be exactly the same as the Log4j 1.x LoggerFactory
interface.

> LoggerFactory in 1.2 API module is not compatible with 1.2
> ----------------------------------------------------------
>
>                 Key: LOG4J2-1336
>                 URL: https://issues.apache.org/jira/browse/LOG4J2-1336
>             Project: Log4j 2
>          Issue Type: Bug
>          Components: log4j 1.2 emulation
>    Affects Versions: 2.5
>            Reporter: Zbynek Vyskovsky
>              Labels: patch
>             Fix For: 2.6
>
>         Attachments: log4j-1.2-compatible-factory.diff
>
>   Original Estimate: 2h
>  Remaining Estimate: 2h
>
> LoggerFactory from log4j 1.2 compatibility layer is not compatible with the original
1.2 version. Therefore software which creates its customized loggers is failing due to AbstractMethodError
error.
> The fix is quite simple - just keep the original interface. The attached patch continues
to support the current method too, but uses different interface name for the functionality
so it doesn't clash with 1.2 API.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: log4j-dev-unsubscribe@logging.apache.org
For additional commands, e-mail: log4j-dev-help@logging.apache.org


Mime
View raw message