logging-log4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Saxtoft" ...@sondagsavisen.dk>
Subject Missing Location information
Date Fri, 18 Oct 2002 12:48:44 GMT
I'm logging to a SocketServer at the moment. On the server I write to a
RollingFileAppender with the format needed to read the file in
LogFactor5. And it works almost fine. I don't get any Location
information. What I get looks like this:

[slf5s.start]18 okt 2002 14:37:48,470[slf5s.DATE]
INFO[slf5s.PRIORITY]
TS[slf5s.NDC]
main[slf5s.THREAD]
dk.son.nms.client.NmsDesktop[slf5s.CATEGORY]
[slf5s.LOCATION]
Loading frame... (FrameReminder)[slf5s.MESSAGE]

Now what I get on the server side, using the same configuration for the
RollingFileAppender is this:

[slf5s.start]18 okt 2002 14:37:48,470[slf5s.DATE]
INFO[slf5s.PRIORITY]
TS[slf5s.NDC]
main[slf5s.THREAD]
dk.son.nms.client.NmsDesktop[slf5s.CATEGORY]
dk.son.nms.client.NmsDesktop.loadFrames(NmsDesktop.java:209)[slf5s.LOCAT
ION]
Loading frame... (FrameReminder)[slf5s.MESSAGE]

The same thing happens with logging on the server, except that the
location information is missing everywhere! Both writing to
SocketAppender and to the RollingFileAppender.

Can anybody tell me what is wrong? Is it a configuration problem or
what?

Thomas Saxtoft

--
To unsubscribe, e-mail:   <mailto:log4j-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:log4j-user-help@jakarta.apache.org>


Mime
View raw message