logging-log4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karr, David" <david.k...@wamu.net>
Subject RE: V1.2.8: RollingFileAppender sometimes loses files when logging across Storage Area Network (SAN)
Date Fri, 19 Aug 2005 16:02:33 GMT
If anyone runs into a similar problem, we're finding that one thing that
seems to make this happen less often (or not at all) is to reduce the
rollover threshold, so each log file is smaller.  I can't say what size
should be used, it might depend on the network.

> -----Original Message-----
> From: Karr, David 
> 
> I wrote about this a few weeks ago, but I've since gotten 
> more specific information about this problem.
> 
> We have a situation where we're using the 
> RollingFileAppender, and writing to log files on a Storage 
> Area Network (SAN).  We have two hosts, clustered with 
> Microsoft Clustering, such that only the active host can see 
> the SAN drive.
> 
> What we see is that after a run of tests, where there should 
> be a consecutive set of log files, there are some missing, 
> both in file name and content.
> 
> We tried doing a similar test, by locating the log files on 
> the local host, and not on the SAN, and we no longer see this problem.
> 
> So, is there some aspect of the RollingFileAppender that 
> might be configurable to help alleviate this?  Is there a 
> different Appender that might not be susceptible to this?
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: log4j-user-unsubscribe@logging.apache.org
> For additional commands, e-mail: log4j-user-help@logging.apache.org
> 
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: log4j-user-unsubscribe@logging.apache.org
For additional commands, e-mail: log4j-user-help@logging.apache.org


Mime
View raw message