logging-log4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Harp, George" <GH...@GAINSystems.com>
Subject RE: Log4j1.1.12 and TRACE level
Date Thu, 06 Oct 2005 16:04:30 GMT
I actually get the class and method names for the other levels error,
debug, warn,info without any additional flags being set:

06-10-2005 10:50:56 INFO      BCConnectionManager gJDBCConnectionInfo
database.minimum.number.of.connections = -1
06-10-2005 10:50:56 INFO      BCConnectionManager gJDBCConnectionInfo
database.connection.pool.class = null
06-10-2005 10:50:56 TRACE     ?                   ?
HELLO WORLD
06-10-2005 10:50:56 INFO      dChefVendorFlatFile readInFlatFile
getOriginalDataLine( ) == 00000002 

The above is the printout I get in the LogFile

-----Original Message-----
From: James Stauffer [mailto:stauffer.james@gmail.com] 
Sent: Thursday, October 06, 2005 11:01 AM
To: Log4J Users List
Subject: Re: Log4j1.1.12 and TRACE level

I think the ? for the method name and class name is probably independant
of using the trace level.  It is probably cause by the classes being
compiled without debug info.

On 10/6/05, Harp, George <GHarp@gainsystems.com> wrote:
> I just downloaded 1.2.12 and tried to use TRACE level. It printed out 
> but I got a ? mark in both the method name and class name parts of my 
> pattern layout.
>
> So C and M.
>
> my entire Log4j.xml file is:
>
>
> <?xml version="1.0" encoding="UTF-8" ?>
>
> <!DOCTYPE log4j:configuration SYSTEM "log4j.dtd">
>
> <!-- Make debug="true" attribute for parsing information -->
>
> <log4j:configuration debug="null"
> xmlns:log4j="http://jakarta.apache.org/log4j/">
>
> <appender name="Console" class="org.apache.log4j.ConsoleAppender">
>
> <layout class="org.apache.log4j.PatternLayout">
>
> <param name="ConversionPattern"
>
> value="%d{dd-MM-yyyy HH:mm:ss} %p %C{1} %M %m%n"/>
>
> </layout>
>
> </appender>
>
> <appender name="LogFile" class="org.apache.log4j.FileAppender">
>
> <param name="File"
>
> value="BatchLogFile.log"/>
>
> <param name="Threshold"
>
> value="TRACE"/>
>
> <param name="Append"
>
> value="false"/>
>
> <layout class="org.apache.log4j.PatternLayout">
>
> <param name="ConversionPattern"
>
> value="%d{dd-MM-yyyy HH:mm:ss} %-9.9p %-19.19C{1} %-19.19M %m%n"/>
>
> </layout>
>
> </appender>
>
> <!-- uncomment this out to get debug for 1 class or package
>
> just change the name element
>
> <logger 
> name="net.gainsystems.log4j.GainsBatchLog4jHeaderFileAppender">
>
> <level value="DEBUG" />
>
> </logger>
>
> -->
>
> <root>
>
> <level value="TRACE"/>
>
> <appender-ref ref="Console"/>
>
> <appender-ref ref="LogFile"/>
>
> </root>
>
> </log4j:configuration>
>
>
>
> Is this a known issue are there work arounds? Did i mess up the setup?
>
>
>


--
James Stauffer
Are you good? Take the test at http://www.livingwaters.com/good/

---------------------------------------------------------------------
To unsubscribe, e-mail: log4j-user-unsubscribe@logging.apache.org
For additional commands, e-mail: log4j-user-help@logging.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: log4j-user-unsubscribe@logging.apache.org
For additional commands, e-mail: log4j-user-help@logging.apache.org


Mime
View raw message