logging-log4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From NehaG <neha.gup...@wipro.com>
Subject JMS Appender Issue - log4j
Date Tue, 26 Aug 2008 05:05:45 GMT

Hi All
I am trying to use JMS Appender of log4j in my application using
log4j.properties file - but its not running.
I am using the jboss-4.2.2.GA Server. The error I am getting is as follows:

log4j:WARN No appenders could be found for
logger(org.jboss.mq.referenceable.SpyConnectionFactoryObjectFactory).
log4j:WARN Please initialize the log4j system properly.

The code does not run ahead of this warning and it stucks there.

I searched a lot but am not able to find the solution.
The log4j.properties file configuration which I am using is as follows:

log4j.rootLogger=DEBUG, jmsapp
log4j.appender.jmsapp=org.apache.log4j.net.JMSAppender
log4j.appender.jmsapp.InitialContextFactoryName=org.jnp.interfaces.NamingContextFactory
log4j.appender.jmsapp.ProviderURL=jnp://localhost:1099
log4j.appender.jmsapp.TopicBindingName=topic/testTopic
log4j.appender.jmsapp.TopicConnectionFactoryBindingName=ConnectionFactory

If someone knows about the problem - please let me know. Any help is a
welcome.

Thanks
Neha
-- 
View this message in context: http://www.nabble.com/JMS-Appender-Issue---log4j-tp19155840p19155840.html
Sent from the Log4j - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: log4j-user-unsubscribe@logging.apache.org
For additional commands, e-mail: log4j-user-help@logging.apache.org


Mime
View raw message