logging-log4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rodney Beede <mailingl...@rodneybeede.com>
Subject Re: can't get UDPAppender to work
Date Mon, 14 Feb 2011 14:54:19 GMT
You probably forgot to add the appender to your root.  A complete copy of
your log4j.xml would help.

On Mon, Feb 14, 2011 at 1:49 AM, rvarum <royv@supportspace.com> wrote:

>
> Hi all,
>
> i'm an automation developer with QTP (not java developer)
>
> i'm trying to configure the log4j of our application to broadcast the log
> messages through UDP protocol using the UDPAppender, so i can't catch and
> process log messages.
>
> the application uses log4j version 1.2.16.
> this is the appender configuration i'm using in the log4j xml conf:
>
>  <appender name="QtpUdpAppender" class="org.apache.log4j.net.UDPAppender">
>
>
>
>    <layout class="org.apache.log4j.xml.XMLLayout">
>
>    </layout>
>  </appender>
>
>
> i used several tools and log4j consoles in order to listen to the UDP port
> on my machine.
> i'm getting nothing from the jboss on that port.
>
> we check all communication issues and there is there is open communication
> between the jboss machine and my machine through the specified UDP port.
>
> is there any special jar need for UDPAppender ?
> or special log4j version ?
> i'm quite in the dark here, and couldn't find lots of information about
> UDPAppender on the net.
>
> any help is appreciated.
>
> thanks,
> Roy.
>
> --
> View this message in context:
> http://old.nabble.com/can%27t-get-UDPAppender-to-work-tp30919617p30919617.html
> Sent from the Log4j - Users mailing list archive at Nabble.com.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: log4j-user-unsubscribe@logging.apache.org
> For additional commands, e-mail: log4j-user-help@logging.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message