logging-log4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Denny Lee <denny_junk_m...@yahoo.com>
Subject Writing binary data to log fine
Date Thu, 05 Apr 2012 23:43:35 GMT
Hello,
I am having trouble trying to log some binary data to the log file. I wrote an application
that receives some log from a network device in binary format; all the app does is take the
output via TCP from the device and writes it to a file.  I wrote the application on Windows
7 computer using Eclipse and I was able to receive the log from the network device, writes
it to a file and then parse the log file with another program.  But when I ran the program
on Redhat 5.5, I was not able to parse the log and got a bunch of errors.  I tried a Windows
log on the Redhat system and used dos2unix on the file and I was able to parse that log just
fine.

Can anyone possibly shed some light on this?  I am not sure where to even begin to troubleshoot
this.  Thanks.

Denny
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message