logging-log4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jacob Kjome" <h...@visi.com>
Subject Re: Log4J doesn't work at all
Date Tue, 10 Apr 2012 17:36:56 GMT
On Tue, 10 Apr 2012 19:23:18 +0200
 tommmmmm <tommmmmm@gmail.com> wrote:
>>
>>
>>   System.setProperty("log4j.**logger.org.apache.http.client"**, "DEBUG");
>>
>> But HttpClient's instructions say to do (again, read the instructions more
>> closely)...
>>      System.setProperty("org.**apache.commons.logging.**
>> simplelog.log.org.apache.http.**wire", "DEBUG");
>>
>>
>For the record, you are refering to HttpClient 3.x
> HttpClient 3.x logging works perfectly for me, straight off the bat.

I'm referring to the page you provided which provides instructions, of which 
the only ones that have anything to do with setting system properties to 
configure logging are the commons-logging examples [1].  In fact, I see no 
mention of version 3.x.  The page appears to be exclusively for 4.x.  If this 
is wrong, then file a bug with the HttpComponents project.

> 
> HttpClient 4.x doesn't work at all. And it has different syntax.
> Just for the sake of it - I used old syntax with new HttpClient - no output
> generated.
> 

What "old" syntax?  The syntax documented on the page?  Again, if that's 
"old", then file a bug with HttpComponents.

In any case, clearly Log4j generally works for you, since it works when you 
log directly as well as with HttpClient-3.x.  The difference appears to be the 
HttpClient version.  Therefore, I suggest you ask the HttpClient developers.  
I'm not sure what else to tell you?


> Tom

[1] 
http://hc.apache.org/httpcomponents-client-ga/logging.html#Commons_Logging_Examples


Jake

---------------------------------------------------------------------
To unsubscribe, e-mail: log4j-user-unsubscribe@logging.apache.org
For additional commands, e-mail: log4j-user-help@logging.apache.org


Mime
View raw message