logging-log4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aliaksandr Belavusau" <abelavu...@gmail.com>
Subject RE: Are the custom appenders only like plugins?
Date Tue, 30 Jul 2013 09:04:33 GMT
Hi Remko,

I've found out that class
org.apache.logging.log4j.core.config.plugins.ResolverUtil is using
org.osgi.framework.wiring.BundleWiring class, and, as I know 
org.osgi.framework.wiring package is available only in osgi.core jar version
4.3.0 or higher. I can use only osgi.core verison 4.2.0 in my OSGi
application.

Any thoughs?

-----Original Message-----
From: Remko Popma [mailto:remkop@yahoo.com] 
Sent: Tuesday, July 30, 2013 2:03 AM
To: Log4J Users List
Subject: Re: Are the custom appenders only like plugins?

Aliaksandr,

I don't think you need a specific OSGi version to make a plugin.

Remko


________________________________
 From: Aliaksandr Belavusau <abelavusau@gmail.com>
To: log4j-user@logging.apache.org 
Sent: Tuesday, July 30, 2013 5:27 AM
Subject: Are the custom appenders only like plugins?
 

Hi Guys,

Trying embed log4j2 in our OSGi application.

So, one small question: How can I create custom appender which will be 
not a plugin? I want to create it like old school log4j1.x appender. The 
cause: We cannot use osgi.core version >= 4.3.0 in our application, only 
=4.2.0. (As you know 4.2.0 does not consist org.osgi.framework.wiring 
package).

Is it possible at all?

Thanks in advance, Alex.


---------------------------------------------------------------------
To unsubscribe, e-mail: log4j-user-unsubscribe@logging.apache.org
For additional commands, e-mail: log4j-user-help@logging.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: log4j-user-unsubscribe@logging.apache.org
For additional commands, e-mail: log4j-user-help@logging.apache.org


Mime
View raw message