logging-log4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Blaine Bergeson (bbergeson)" <bberge...@micron.com>
Subject RE: Standard Out stops working
Date Fri, 29 Jan 2016 18:30:17 GMT
Sure.  I am running on Windows 7 Enterprise 64 bit.  I am also using the 64 bit version of
java 1.8 update 60.  I have to use a 64 bit version of java because the driver that my code
is communicating with is 64 bit.  I am running Log4j version 2.1 and  I attached my configuration
file.

Thx Blaine

-----Original Message-----
From: Ralph Goers [mailto:ralph.goers@dslextreme.com] 
Sent: Friday, January 29, 2016 10:31 AM
To: Log4J Users List
Subject: Re: Standard Out stops working

Can you provide more information on your configuration and OS? What Log4j 2 version are you
using?

Ralph

> On Jan 29, 2016, at 8:19 AM, Blaine Bergeson (bbergeson) <bbergeson@micron.com>
wrote:
> 
> I have been using Log4j for a while now without any major problems but now I am experiencing
a strange problem.  If I build a simple java app and run it from the command line, as soon
as I call Configurator.initialize standard out stops working.  I called the System.out.checkError
method and indeed the stream is in an error state.  I added the following property -Dorg.apache.logging.log4j.simplelog.StatusLogger.level=TRACE
and then ran again which produced the following output.  I am not sure if any of the items
listed below is a problem or not.  I am using the same log4j2.xml file I have used in other
projects.  When I run the project inside NetBeans everything runs fine.
>  
> 
>  
> Thx Blaine


Mime
View raw message