logging-log4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Scott Deboy <scott.de...@gmail.com>
Subject Re: Zero conf is not showing logs even it's connected
Date Fri, 04 Mar 2016 20:00:25 GMT
I don't know why it would say remote host refused connection.  Are
there any other errors or warnings in the chainsaw-log tab generated
when you double-click the zeroconf entry?

On 3/4/16, Bilguun Ariunbold <ariunboldbiliguun@gmail.com> wrote:
> Hi Scott,
>
> Thank you for your respond.
>
> Are you running Chainsaw on the same machine as the app using this
> log4j2 appender config?
>
> -Yes I am, I checked a file by opening through web browsers by advertiseUri
> and it was opened successfully. (Once I tested on my local, I'll separate
> them to the different machines). As far as I know, chainsaw uses 4555 as
> default port, was I supposed to specify different port in my appender
> definition?
>
> On Fri, Mar 4, 2016 at 2:30 PM, Scott Deboy <scott.deboy@gmail.com> wrote:
>
>> Are you running Chainsaw on the same machine as the app using this
>> log4j2 appender config?
>>
>> Chainsaw will try to load the advertiseURL directly:
>> file:///C://users/bilguuna/logs/webapp.log
>>
>> If Chainsaw is on a separate machine, multicast packets need to be
>> able to flow between your environment using this log4j2 appender and
>> Chainsaw, and then the advertiseURL needs to also be accessible from
>> Chainsaw.
>>
>> If you are running this log4j2 appender config on a Linux box and
>> multicast is available across your network, you would need to use a
>> Commons-VFS supported URI in your advertiseURL in order to have
>> Chainsaw tail the logs.
>>
>> Something like this for an advertiseURL:
>>
>> advertiseURI="sftp://myuser:mypass@hostname/path/to/logfile"
>>
>>
>>
>> On 3/4/16, Bilguun Ariunbold <ariunboldbiliguun@gmail.com> wrote:
>> > Hi,
>> >
>> >
>> >
>> > I’ve been trying to see logs using Chainsaw ZeroConf but it is not
>> showing
>> > me any logs even though it has “Connected” connection status.
>> >
>> >
>> > My workspace:
>> >
>> > Tomcat 8,
>> >
>> > Log4j2.5
>> >
>> > Chainsaw v2
>> >
>> > I added javax.jmdns:jmdns as a dependency to the project
>> >
>> >
>> > Here is my log4j.xml:
>> >
>> > <?xml version=*"1.0"* encoding=*"UTF-8"*?>
>> >
>> > <Configuration status=*"INFO"* advertiser=*"multicastdns"*>
>> >
>> >        <Properties>
>> >
>> >               <Property name=*"layout"*>%d | %-5p | [%t] | %c{2} | %M
|
>> > %m%n
>> >
>> >               </Property>
>> >
>> >        </Properties>
>> >
>> >        <Appenders>
>> >
>> >               <Console name=*"Console"* target=*"SYSTEM_OUT"*>
>> >
>> >                      <PatternLayout pattern=*"${layout}"* />
>> >
>> >               </Console>
>> >
>> >               <File name=*"Errors"* fileName=
>> > *"${sys:user.home}/logs/webapp-errors.log"*
>> >
>> >                      filePattern=
>> > *"${sys:user.home}/logs/webapp-errors-%d{yyyy-MM-dd}-%i.log"*>
>> >
>> >                      <Policies>
>> >
>> >                            <TimeBasedTriggeringPolicy />
>> >
>> >                            <SizeBasedTriggeringPolicy size=*"1 MB"* />
>> >
>> >                      </Policies>
>> >
>> >                      <DefaultRolloverStrategy max=*"10"* />
>> >
>> >                      <JSONLayout>
>> >
>> >                      </JSONLayout>
>> >
>> >               </File>
>> >
>> >               <RollingFile name=*"LogFile"* fileName=
>> > *"${sys:user.home}/logs/webapp.log"*
>> >
>> >                      filePattern=
>> > *"${sys:user.home}/logs/webapp-%d{yyyy-MM-dd}-%i.log"*
>> >
>> >                      bufferedIO=*"false"* advertiseURI=
>> > *"file:///C://users/bilguuna/logs/webapp.log"*
>> >
>> >                      advertise=*"true"*>
>> >
>> >                      <PatternLayout pattern=*"${layout}"* />
>> >
>> >                      <Policies>
>> >
>> >                            <TimeBasedTriggeringPolicy />
>> >
>> >                            <SizeBasedTriggeringPolicy size=*"1 MB"* />
>> >
>> >                      </Policies>
>> >
>> >                      <DefaultRolloverStrategy max=*"10"* />
>> >
>> >               </RollingFile>
>> >
>> >        </Appenders>
>> >
>> >        <Loggers>
>> >
>> >               <Root level=*"INFO"*>
>> >
>> >                      <AppenderRef ref=*"Console"* level=*"WARN"* />
>> >
>> >                      <AppenderRef ref=*"Errors"* level=*"WARN"* />
>> >
>> >                      <AppenderRef ref=*"LogFile"* level=*"INFO"* />
>> >
>> >               </Root>
>> >
>> >        </Loggers>
>> >
>> > </Configuration>
>> >
>> >
>> > On the ZeroConf tab, I see 2 receivers which are configuration and
>> LogFile
>> > that both are connected. When I double click any of them, it just
>> > changes
>> > Connection status but not showing any logs. What should I do?
>> >
>> >
>> > Update: I realized that in zeroconf folder of the chainsaw-log tab, it
>> said
>> > Remote host [10.20.91.20] refused connection. Is that might be the
>> reason?
>> >
>> >
>> > Thank you
>> >
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: log4j-user-unsubscribe@logging.apache.org
>> For additional commands, e-mail: log4j-user-help@logging.apache.org
>>
>>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: log4j-user-unsubscribe@logging.apache.org
For additional commands, e-mail: log4j-user-help@logging.apache.org


Mime
View raw message