logging-log4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Scott Deboy <scott.de...@gmail.com>
Subject Re: Zero conf is not showing logs even it's connected
Date Sat, 05 Mar 2016 03:13:31 GMT
To clarify, the 'people' path is going away - the new permanent path is:

http://home.apache.org/~sdeboy


On 3/4/16, Scott Deboy <scott.deboy@gmail.com> wrote:
> I've uploaded the developer snapshot to http://people.apache.org/~sdeboy/
>
> Extract the tarball and run bin/chainsaw
>
> It should work out-of-the-box with your current configuration.
>
> Scott
>
>
> On 3/4/16, Matt Sicker <boards@gmail.com> wrote:
>> Oh no they finally shut down people.apache.org!
>>
>> On 4 March 2016 at 14:36, Bilguun Ariunbold <ariunboldbiliguun@gmail.com>
>> wrote:
>>
>>> Thank you Scott, the link you sent me was not found. Where should I get
>>> that snapshot?
>>>
>>> On Fri, Mar 4, 2016 at 3:33 PM, Scott Deboy <scott.deboy@gmail.com>
>>> wrote:
>>>
>>> > You need to use the latest developer snapshot of chainsaw to work with
>>> > log4j2. Need to see if it is still on http://people.apache.org/~sdeboy
>>> > On Mar 4, 2016 12:18 PM, "Bilguun Ariunbold" <
>>> ariunboldbiliguun@gmail.com>
>>> > wrote:
>>> >
>>> > > Okay, let me clarify this. I am using chainsawWebStart.jnlp to start
>>> > > chainsaw and I choose "Let me define Receivers manually" when it
>>> > complained
>>> > > "Warning:You have no Receivers defined...".
>>> > > When I double click on a row in Zeroconf tab, it just changes
>>> connection
>>> > > status to Connected/Not Connected. So, when I click chainsaw-log
>>> > > tab,
>>> > below
>>> > > messages are repeated there as a grid:
>>> > >
>>> > > Attempting connection to 10.20.91.2/which is my machine's ip
>>> > > address/
>>> > > Remote host 10.20.91.29 refused connection.
>>> > > waiting for 30000 milliseconds before reconnection
>>> > >
>>> > >
>>> > >
>>> > > My machine is Windows pc. Was I supposed to be administrator of my
>>> > > machine? I don't need log4j-zeroconf.jar, do I?
>>> > >
>>> > >
>>> > > Thanks
>>> > >
>>> > >
>>> > >
>>> > >
>>> > >
>>> > >
>>> > > On Fri, Mar 4, 2016 at 3:00 PM, Scott Deboy <scott.deboy@gmail.com>
>>> > wrote:
>>> > >
>>> > > > I don't know why it would say remote host refused connection.
 Are
>>> > > > there any other errors or warnings in the chainsaw-log tab
>>> > > > generated
>>> > > > when you double-click the zeroconf entry?
>>> > > >
>>> > > > On 3/4/16, Bilguun Ariunbold <ariunboldbiliguun@gmail.com>
wrote:
>>> > > > > Hi Scott,
>>> > > > >
>>> > > > > Thank you for your respond.
>>> > > > >
>>> > > > > Are you running Chainsaw on the same machine as the app using
>>> > > > > this
>>> > > > > log4j2 appender config?
>>> > > > >
>>> > > > > -Yes I am, I checked a file by opening through web browsers
by
>>> > > > advertiseUri
>>> > > > > and it was opened successfully. (Once I tested on my local,
I'll
>>> > > separate
>>> > > > > them to the different machines). As far as I know, chainsaw
uses
>>> 4555
>>> > > as
>>> > > > > default port, was I supposed to specify different port in
my
>>> appender
>>> > > > > definition?
>>> > > > >
>>> > > > > On Fri, Mar 4, 2016 at 2:30 PM, Scott Deboy
>>> > > > > <scott.deboy@gmail.com
>>> >
>>> > > > wrote:
>>> > > > >
>>> > > > >> Are you running Chainsaw on the same machine as the app
using
>>> > > > >> this
>>> > > > >> log4j2 appender config?
>>> > > > >>
>>> > > > >> Chainsaw will try to load the advertiseURL directly:
>>> > > > >> file:///C://users/bilguuna/logs/webapp.log
>>> > > > >>
>>> > > > >> If Chainsaw is on a separate machine, multicast packets
need to
>>> > > > >> be
>>> > > > >> able to flow between your environment using this log4j2
>>> > > > >> appender
>>> and
>>> > > > >> Chainsaw, and then the advertiseURL needs to also be
accessible
>>> from
>>> > > > >> Chainsaw.
>>> > > > >>
>>> > > > >> If you are running this log4j2 appender config on a Linux
box
>>> > > > >> and
>>> > > > >> multicast is available across your network, you would
need to
>>> > > > >> use
>>> a
>>> > > > >> Commons-VFS supported URI in your advertiseURL in order
to have
>>> > > > >> Chainsaw tail the logs.
>>> > > > >>
>>> > > > >> Something like this for an advertiseURL:
>>> > > > >>
>>> > > > >> advertiseURI="sftp://myuser:mypass@hostname/path/to/logfile"
>>> > > > >>
>>> > > > >>
>>> > > > >>
>>> > > > >> On 3/4/16, Bilguun Ariunbold <ariunboldbiliguun@gmail.com>
>>> > > > >> wrote:
>>> > > > >> > Hi,
>>> > > > >> >
>>> > > > >> >
>>> > > > >> >
>>> > > > >> > I’ve been trying to see logs using Chainsaw ZeroConf
but it
>>> > > > >> > is
>>> not
>>> > > > >> showing
>>> > > > >> > me any logs even though it has “Connected” connection
status.
>>> > > > >> >
>>> > > > >> >
>>> > > > >> > My workspace:
>>> > > > >> >
>>> > > > >> > Tomcat 8,
>>> > > > >> >
>>> > > > >> > Log4j2.5
>>> > > > >> >
>>> > > > >> > Chainsaw v2
>>> > > > >> >
>>> > > > >> > I added javax.jmdns:jmdns as a dependency to the
project
>>> > > > >> >
>>> > > > >> >
>>> > > > >> > Here is my log4j.xml:
>>> > > > >> >
>>> > > > >> > <?xml version=*"1.0"* encoding=*"UTF-8"*?>
>>> > > > >> >
>>> > > > >> > <Configuration status=*"INFO"* advertiser=*"multicastdns"*>
>>> > > > >> >
>>> > > > >> >        <Properties>
>>> > > > >> >
>>> > > > >> >               <Property name=*"layout"*>%d
| %-5p | [%t] |
>>> %c{2} |
>>> > > %M
>>> > > > |
>>> > > > >> > %m%n
>>> > > > >> >
>>> > > > >> >               </Property>
>>> > > > >> >
>>> > > > >> >        </Properties>
>>> > > > >> >
>>> > > > >> >        <Appenders>
>>> > > > >> >
>>> > > > >> >               <Console name=*"Console"*
>>> > > > >> > target=*"SYSTEM_OUT"*>
>>> > > > >> >
>>> > > > >> >                      <PatternLayout pattern=*"${layout}"*
/>
>>> > > > >> >
>>> > > > >> >               </Console>
>>> > > > >> >
>>> > > > >> >               <File name=*"Errors"* fileName=
>>> > > > >> > *"${sys:user.home}/logs/webapp-errors.log"*
>>> > > > >> >
>>> > > > >> >                      filePattern=
>>> > > > >> > *"${sys:user.home}/logs/webapp-errors-%d{yyyy-MM-dd}-%i.log"*>
>>> > > > >> >
>>> > > > >> >                      <Policies>
>>> > > > >> >
>>> > > > >> >                            <TimeBasedTriggeringPolicy
/>
>>> > > > >> >
>>> > > > >> >                            <SizeBasedTriggeringPolicy
>>> > > > >> > size=*"1
>>> > MB"*
>>> > > />
>>> > > > >> >
>>> > > > >> >                      </Policies>
>>> > > > >> >
>>> > > > >> >                      <DefaultRolloverStrategy
max=*"10"* />
>>> > > > >> >
>>> > > > >> >                      <JSONLayout>
>>> > > > >> >
>>> > > > >> >                      </JSONLayout>
>>> > > > >> >
>>> > > > >> >               </File>
>>> > > > >> >
>>> > > > >> >               <RollingFile name=*"LogFile"* fileName=
>>> > > > >> > *"${sys:user.home}/logs/webapp.log"*
>>> > > > >> >
>>> > > > >> >                      filePattern=
>>> > > > >> > *"${sys:user.home}/logs/webapp-%d{yyyy-MM-dd}-%i.log"*
>>> > > > >> >
>>> > > > >> >                      bufferedIO=*"false"* advertiseURI=
>>> > > > >> > *"file:///C://users/bilguuna/logs/webapp.log"*
>>> > > > >> >
>>> > > > >> >                      advertise=*"true"*>
>>> > > > >> >
>>> > > > >> >                      <PatternLayout pattern=*"${layout}"*
/>
>>> > > > >> >
>>> > > > >> >                      <Policies>
>>> > > > >> >
>>> > > > >> >                            <TimeBasedTriggeringPolicy
/>
>>> > > > >> >
>>> > > > >> >                            <SizeBasedTriggeringPolicy
>>> > > > >> > size=*"1
>>> > MB"*
>>> > > />
>>> > > > >> >
>>> > > > >> >                      </Policies>
>>> > > > >> >
>>> > > > >> >                      <DefaultRolloverStrategy
max=*"10"* />
>>> > > > >> >
>>> > > > >> >               </RollingFile>
>>> > > > >> >
>>> > > > >> >        </Appenders>
>>> > > > >> >
>>> > > > >> >        <Loggers>
>>> > > > >> >
>>> > > > >> >               <Root level=*"INFO"*>
>>> > > > >> >
>>> > > > >> >                      <AppenderRef ref=*"Console"*
>>> > > > >> > level=*"WARN"*
>>> > />
>>> > > > >> >
>>> > > > >> >                      <AppenderRef ref=*"Errors"*
>>> > > > >> > level=*"WARN"*
>>> />
>>> > > > >> >
>>> > > > >> >                      <AppenderRef ref=*"LogFile"*
>>> > > > >> > level=*"INFO"*
>>> > />
>>> > > > >> >
>>> > > > >> >               </Root>
>>> > > > >> >
>>> > > > >> >        </Loggers>
>>> > > > >> >
>>> > > > >> > </Configuration>
>>> > > > >> >
>>> > > > >> >
>>> > > > >> > On the ZeroConf tab, I see 2 receivers which are
>>> > > > >> > configuration
>>> and
>>> > > > >> LogFile
>>> > > > >> > that both are connected. When I double click any
of them, it
>>> just
>>> > > > >> > changes
>>> > > > >> > Connection status but not showing any logs. What
should I do?
>>> > > > >> >
>>> > > > >> >
>>> > > > >> > Update: I realized that in zeroconf folder of the
>>> > > > >> > chainsaw-log
>>> > tab,
>>> > > it
>>> > > > >> said
>>> > > > >> > Remote host [10.20.91.20] refused connection. Is
that might
>>> > > > >> > be
>>> the
>>> > > > >> reason?
>>> > > > >> >
>>> > > > >> >
>>> > > > >> > Thank you
>>> > > > >> >
>>> > > > >>
>>> > > > >>
>>> > ---------------------------------------------------------------------
>>> > > > >> To unsubscribe, e-mail:
>>> > > > >> log4j-user-unsubscribe@logging.apache.org
>>> > > > >> For additional commands, e-mail:
>>> log4j-user-help@logging.apache.org
>>> > > > >>
>>> > > > >>
>>> > > > >
>>> > > >
>>> > > > ---------------------------------------------------------------------
>>> > > > To unsubscribe, e-mail: log4j-user-unsubscribe@logging.apache.org
>>> > > > For additional commands, e-mail:
>>> > > > log4j-user-help@logging.apache.org
>>> > > >
>>> > > >
>>> > >
>>> >
>>>
>>
>>
>>
>> --
>> Matt Sicker <boards@gmail.com>
>>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: log4j-user-unsubscribe@logging.apache.org
For additional commands, e-mail: log4j-user-help@logging.apache.org


Mime
View raw message