lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Tucker <>
Subject Re: JDK compatibility (Collections API)
Date Wed, 08 Oct 2003 14:03:04 GMT

We've found that Lucene essentially requires JDK 1.3.1 or later because 
of some VM bugs in 1.3.0. Perhaps Lucene would also work with 1.2.x VM's 
(we haven't tested)? However, trying to preserve compatability with 
1.1.x seems just silly. It would be premature to require JDK 1.4.x, but 
virtually everyone uses 1.3 or 1.4. And, even though some small few 
don't, I don't think that's a good enough reason to shackle Lucene to a 
very old VM version. That's just my opinion though. :)


Tatu Saloranta wrote:

> I think this has been briefly discussed in the past, but what is the consensus
> on using parts of JDK API only available in releases later than 1.1.x?
> I'm specifically thinking of Collections, which was introduced for 1.2.x 
> (although was available as separate package for 1.1.x I believe).
> I'm not sure if there already are other dependencies to 1.2.x, if so, what are 
> those?
> In general I think it is good idea to try to avoid having dependencies to 
> newest releases, at least on core Lucene classes... but in case of 
> Collections I'd really like to be able to use those classes.
> What do others think?
> Alternatively if 1.1.x compatibility really is a high priority, it's 
> oftentimes possible to write wrappers and store them (say, Hits wrapper)
> in different optional package.
> What do others think?
> -+ Tatu +-
> ---------------------------------------------------------------------
> To unsubscribe, e-mail:
> For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message