lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Doug Cutting <>
Subject Re: patch - DEFAULT_ vars in IndexWriter non-final and DEFAULT for useCompoundFile
Date Mon, 28 Feb 2005 22:38:06 GMT
Kevin A. Burton wrote:
> Wolf Siberski wrote:
>> Kevin A. Burton wrote:
>> I see following issues with your patch:
>> - you changed the DEFAULT_... semantics from constant to modifiable,
>>   but didn't adjust the names according to Java conventions 
>> (default_...).
> Java doesn't have any naming conventions which include an underscore.
> I assume you mean defautUse ...

>> - you can achieve the same by writing your own IndexWriterFactory which
>>   sets the corresponding values after creating a new IndexWriter.
>>   Should be ~30 lines of code. It only makes sense to include a
>>   patch if either a solution is impossible with the current code
>>   or *a lot* of (potential) users have to work around something.
> I *could* (and I thought of it) but it seems reasonable to be able to 
> set Lucene to use whatever settings you
> want at anytime...

You could do exactly that with an IndexWriterFactory, that's Wolf's point.


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message