lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Harwood (JIRA)" <>
Subject [jira] Commented: (LUCENE-584) Decouple Filter from BitSet
Date Mon, 03 Dec 2007 21:13:43 GMT


Mark Harwood commented on LUCENE-584:

I'm getting lost as to which patches we're considering here. I was looking at lucene-584-take2

MatcherProvider in the earlier patch does look like something that will help with caching.

>>Would those be a good starting point?

Overall I feel uncomfortable with a lot of the classnames. I think the use of "Matcher" says
more about what you want to do with the class in this particular case rather than what _it_
does generally. I have other uses in mind for these classes that are outside of filtering
search results. For me, these classes can be thought of much more simply as utility classes
in the same mould as the java Collections API. Fundamentally, they are efficient implementations
of sets/lists of integers with support for iterators. The whole thing would be a lot cleaner
if classes were named around this scheme.
"MatcherProvider" for example is essentially a DocIdSet  which creates forms of DocIdSetIterators
(Matchers) and could also usefully have a size() method. 

> Decouple Filter from BitSet
> ---------------------------
>                 Key: LUCENE-584
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Search
>    Affects Versions: 2.0.1
>            Reporter: Peter Schäfer
>            Assignee: Michael Busch
>            Priority: Minor
>         Attachments: bench-diff.txt, bench-diff.txt, lucene-584-take2.patch, lucene-584.patch,
Matcher-20070905-2default.patch, Matcher-20070905-3core.patch, Matcher-20071122-1ground.patch,
> {code}
> package;
> public abstract class Filter implements 
> {
>   public abstract AbstractBitSet bits(IndexReader reader) throws IOException;
> }
> public interface AbstractBitSet 
> {
>   public boolean get(int index);
> }
> {code}
> It would be useful if the method =Filter.bits()= returned an abstract interface, instead
of =java.util.BitSet=.
> Use case: there is a very large index, and, depending on the user's privileges, only
a small portion of the index is actually visible.
> Sparsely populated =java.util.BitSet=s are not efficient and waste lots of memory. It
would be desirable to have an alternative BitSet implementation with smaller memory footprint.
> Though it _is_ possibly to derive classes from =java.util.BitSet=, it was obviously not
designed for that purpose.
> That's why I propose to use an interface instead. The default implementation could still
delegate to =java.util.BitSet=.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message