lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul Elschot (JIRA)" <>
Subject [jira] Commented: (LUCENE-584) Decouple Filter from BitSet
Date Sun, 02 Dec 2007 10:57:43 GMT


Paul Elschot commented on LUCENE-584:

I tried implementing a Searchable, and indeed ran into compilation errors.
So, backward compatibility is indeed not complete.

Also, Searchable is an interface, so it should not be changed.
In case there are other interfaces affected by the patch these should not be changed either.

There are two ways out of this:

Do a name change on MatcherFilter/Filter -> Filter/BitSetFilter.
Changing the current Filter to BitSetFilter gives other problems with contrib packages.
I tried this some time ago, see above, but I could not make it work.

I'd prefer to add an interface (or abstract class?) like Searchable that uses MatchFilter
for those implementers that want to take advantage of MatchFilter.
I don't expect problems from leaving the Searchable interface available unchanged.
Other interfaces that use Filter can be treated the same way, in case there are any.

> Decouple Filter from BitSet
> ---------------------------
>                 Key: LUCENE-584
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Search
>    Affects Versions: 2.0.1
>            Reporter: Peter Schäfer
>            Assignee: Michael Busch
>            Priority: Minor
>         Attachments: bench-diff.txt, bench-diff.txt, lucene-584.patch, Matcher-20070905-2default.patch,
Matcher-20070905-3core.patch, Matcher-20071122-1ground.patch, Some
> {code}
> package;
> public abstract class Filter implements 
> {
>   public abstract AbstractBitSet bits(IndexReader reader) throws IOException;
> }
> public interface AbstractBitSet 
> {
>   public boolean get(int index);
> }
> {code}
> It would be useful if the method =Filter.bits()= returned an abstract interface, instead
of =java.util.BitSet=.
> Use case: there is a very large index, and, depending on the user's privileges, only
a small portion of the index is actually visible.
> Sparsely populated =java.util.BitSet=s are not efficient and waste lots of memory. It
would be desirable to have an alternative BitSet implementation with smaller memory footprint.
> Though it _is_ possibly to derive classes from =java.util.BitSet=, it was obviously not
designed for that purpose.
> That's why I propose to use an interface instead. The default implementation could still
delegate to =java.util.BitSet=.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message