lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marvin Humphrey (JIRA)" <>
Subject [jira] Commented: (LUCENE-1614) Add next() and skipTo() variants to DocIdSetIterator that return the current doc, instead of boolean
Date Mon, 18 May 2009 15:40:46 GMT


Marvin Humphrey commented on LUCENE-1614:

> if a set has docs 9, 10, 11 and I call skipTo(10) and then doc() I'll get 10 
> the first time and 11 the second time 

> I was wondering if we want to change it,

I agree that your proposed definition is more intuitive.  I think it 
might make TermScorer.advance() a tad less efficient, though,
because it would be necessary to check the current doc first.

  public boolean skipTo(int target) throws IOException {
    // first scan in cache
    for (pointer++; pointer < pointerMax; pointer++) {
       if (docs[pointer] >= target) {
         doc = docs[pointer];
         return true;

There might be others, as well. I'd be concerned if something
low-level like TermDocs or TermPositions was affected 
negatively.  It seems likely, because we'd be changing from
"advance, then check state" to "check state, then advance, 
then check state". 

Funny, but this is actually closer to "skip to" than "advance", since
under this proposal, the iterator would not always advance.  

> Add next() and skipTo() variants to DocIdSetIterator that return the current doc, instead
of boolean
> ----------------------------------------------------------------------------------------------------
>                 Key: LUCENE-1614
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Search
>            Reporter: Shai Erera
>             Fix For: 2.9
> See
for the full discussion. The basic idea is to add variants to those two methods that return
the current doc they are at, to save successive calls to doc(). If there are no more docs,
return -1. A summary of what was discussed so far:
> # Deprecate those two methods.
> # Add nextDoc() and skipToDoc(int) that return doc, with default impl in DISI (calls
next() and skipTo() respectively, and will be changed to abstract in 3.0).
> #* I actually would like to propose an alternative to the names: advance() and advance(int)
- the first advances by one, the second advances to target.
> # Wherever these are used, do something like '(doc = advance()) >= 0' instead of comparing
to -1 for improved performance.
> I will post a patch shortly

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message