lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yonik Seeley <yo...@lucidimagination.com>
Subject Re: Lucene's default settings & back compatibility
Date Tue, 19 May 2009 18:27:33 GMT
On Tue, May 19, 2009 at 2:04 PM, Michael McCandless
<lucene@mikemccandless.com> wrote:
> On Tue, May 19, 2009 at 9:34 AM, Yonik Seeley
> <yonik@lucidimagination.com> wrote:
>
>> Selecting backward compatibility vs latest and greatest could be done
>> w/o Settings (a simple static int containing the version number to act
>> like).  It seems like the Settings debate should be based on it's own
>> merits.
>
> But isn't a static int too restrictive?  That means all usage of
> Lucene from within this JRE must match that version?

Isn't that currently the case though?  One Lucene jar, one behavior.

-Yonik

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message